stress-ng_0.11.23.bb 901 B

123456789101112131415161718192021222324252627
  1. SUMMARY = "System load testing utility"
  2. DESCRIPTION = "Deliberately simple workload generator for POSIX systems. It \
  3. imposes a configurable amount of CPU, memory, I/O, and disk stress on the system."
  4. HOMEPAGE = "https://kernel.ubuntu.com/~cking/stress-ng/"
  5. LICENSE = "GPLv2"
  6. LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
  7. SRC_URI = "https://kernel.ubuntu.com/~cking/tarballs/${BPN}/${BP}.tar.xz \
  8. file://0001-Do-not-preserve-ownership-when-installing-example-jo.patch \
  9. file://no_daddr_t.patch \
  10. "
  11. SRC_URI[sha256sum] = "c0a76147a02f4c31af1fb4b9b7e0b90ac8bbd8590ccb54264d5cbe046c769cd2"
  12. DEPENDS = "coreutils-native"
  13. PROVIDES = "stress"
  14. RPROVIDES_${PN} = "stress"
  15. RREPLACES_${PN} = "stress"
  16. RCONFLICTS_${PN} = "stress"
  17. inherit bash-completion
  18. do_install() {
  19. oe_runmake DESTDIR=${D} install
  20. ln -s stress-ng ${D}${bindir}/stress
  21. }