ethtool_5.9.bb 1.4 KB

12345678910111213141516171819202122232425262728293031323334353637
  1. SUMMARY = "Display or change ethernet card settings"
  2. DESCRIPTION = "A small utility for examining and tuning the settings of your ethernet-based network interfaces."
  3. HOMEPAGE = "http://www.kernel.org/pub/software/network/ethtool/"
  4. SECTION = "console/network"
  5. LICENSE = "GPLv2+"
  6. LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
  7. file://ethtool.c;beginline=4;endline=17;md5=c19b30548c582577fc6b443626fc1216"
  8. SRC_URI = "${KERNELORG_MIRROR}/software/network/ethtool/ethtool-${PV}.tar.gz \
  9. file://run-ptest \
  10. file://avoid_parallel_tests.patch \
  11. "
  12. SRC_URI[sha256sum] = "f934a830554c46d7d60b1a9147f4cab15589b7e09344c4b79b1948b740f0a725"
  13. UPSTREAM_CHECK_URI = "https://www.kernel.org/pub/software/network/ethtool/"
  14. inherit autotools ptest bash-completion pkgconfig
  15. RDEPENDS_${PN}-ptest += "make"
  16. PACKAGECONFIG ?= "netlink"
  17. PACKAGECONFIG[netlink] = "--enable-netlink,--disable-netlink,libmnl,"
  18. do_compile_ptest() {
  19. oe_runmake buildtest-TESTS
  20. }
  21. do_install_ptest () {
  22. cp ${B}/Makefile ${D}${PTEST_PATH}
  23. install ${B}/test-cmdline ${D}${PTEST_PATH}
  24. if ${@bb.utils.contains('PACKAGECONFIG', 'netlink', 'false', 'true', d)}; then
  25. install ${B}/test-features ${D}${PTEST_PATH}
  26. fi
  27. install ${B}/ethtool ${D}${PTEST_PATH}/ethtool
  28. sed -i 's/^Makefile/_Makefile/' ${D}${PTEST_PATH}/Makefile
  29. }