qemu-system-native_5.1.0.bb 915 B

1234567891011121314151617181920212223242526
  1. BPN = "qemu"
  2. require qemu-native.inc
  3. # As some of the files installed by qemu-native and qemu-system-native
  4. # are the same, we depend on qemu-native to get the full installation set
  5. # and avoid file clashes
  6. DEPENDS = "glib-2.0-native zlib-native pixman-native qemu-native bison-native"
  7. EXTRA_OECONF_append = " --target-list=${@get_qemu_system_target_list(d)}"
  8. PACKAGECONFIG ??= "fdt alsa kvm \
  9. ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'virglrenderer glx', '', d)} \
  10. "
  11. # Handle distros such as CentOS 5 32-bit that do not have kvm support
  12. PACKAGECONFIG_remove = "${@'kvm' if not os.path.exists('/usr/include/linux/kvm.h') else ''}"
  13. do_install_append() {
  14. install -Dm 0755 ${WORKDIR}/powerpc_rom.bin ${D}${datadir}/qemu
  15. # The following is also installed by qemu-native
  16. rm -f ${D}${datadir}/qemu/trace-events-all
  17. rm -rf ${D}${datadir}/qemu/keymaps
  18. rm -rf ${D}${datadir}/icons/
  19. }