ninja_1.10.1.bb 674 B

123456789101112131415161718192021222324252627282930
  1. SUMMARY = "Ninja is a small build system with a focus on speed."
  2. HOMEPAGE = "https://ninja-build.org/"
  3. LICENSE = "Apache-2.0"
  4. LIC_FILES_CHKSUM = "file://COPYING;md5=a81586a64ad4e476c791cda7e2f2c52e"
  5. DEPENDS = "re2c-native ninja-native"
  6. SRCREV = "a1f879b29c9aafe6a2bc0ba885701f8f4f19f772"
  7. SRC_URI = "git://github.com/ninja-build/ninja.git;branch=release"
  8. UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>.*)"
  9. S = "${WORKDIR}/git"
  10. do_configure[noexec] = "1"
  11. do_compile_class-native() {
  12. python3 ./configure.py --bootstrap
  13. }
  14. do_compile() {
  15. python3 ./configure.py
  16. ninja
  17. }
  18. do_install() {
  19. install -D -m 0755 ${S}/ninja ${D}${bindir}/ninja
  20. }
  21. BBCLASSEXTEND = "native nativesdk"