Browse Source

meta/lib+scripts: Convert to SPDX license headers

This adds SPDX license headers in place of the wide assortment of things
currently in our script headers. We default to GPL-2.0-only except for the
oeqa code where it was clearly submitted and marked as MIT on the most part
or some scripts which had the "or later" GPL versioning.

The patch also drops other obsolete bits of file headers where they were
encoountered such as editor modelines, obsolete maintainer information or
the phrase "All rights reserved" which is now obsolete and not required in
copyright headers (in this case its actually confusing for licensing as all
rights were not reserved).

More work is needed for OE-Core but this takes care of the bulk of the scripts
and meta/lib directories.

The top level LICENSE files are tweaked to match the new structure and the
SPDX naming.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Richard Purdie 5 years ago
parent
commit
f8c9c511b5
100 changed files with 375 additions and 162 deletions
  1. 15 9
      LICENSE
  2. 5 56
      LICENSE.GPL-2.0-only
  3. 10 2
      LICENSE.MIT
  4. 0 17
      meta-skeleton/COPYING.MIT
  5. 4 0
      meta/lib/bblayers/create.py
  6. 3 0
      meta/lib/buildstats.py
  7. 4 0
      meta/lib/oe/__init__.py
  8. 2 0
      meta/lib/oe/buildhistory_analysis.py
  9. 2 0
      meta/lib/oe/cachedpath.py
  10. 4 0
      meta/lib/oe/classextend.py
  11. 3 0
      meta/lib/oe/classutils.py
  12. 3 0
      meta/lib/oe/copy_buildsystem.py
  13. 4 0
      meta/lib/oe/data.py
  14. 4 0
      meta/lib/oe/distro_check.py
  15. 4 0
      meta/lib/oe/elf.py
  16. 4 0
      meta/lib/oe/gpg_sign.py
  17. 3 1
      meta/lib/oe/license.py
  18. 4 0
      meta/lib/oe/lsb.py
  19. 3 0
      meta/lib/oe/maketype.py
  20. 4 0
      meta/lib/oe/manifest.py
  21. 4 0
      meta/lib/oe/package.py
  22. 4 0
      meta/lib/oe/package_manager.py
  23. 4 0
      meta/lib/oe/packagedata.py
  24. 4 0
      meta/lib/oe/packagegroup.py
  25. 4 0
      meta/lib/oe/patch.py
  26. 4 0
      meta/lib/oe/path.py
  27. 3 0
      meta/lib/oe/prservice.py
  28. 4 0
      meta/lib/oe/qa.py
  29. 2 0
      meta/lib/oe/recipeutils.py
  30. 3 0
      meta/lib/oe/rootfs.py
  31. 4 0
      meta/lib/oe/sdk.py
  32. 3 0
      meta/lib/oe/sstatesig.py
  33. 3 0
      meta/lib/oe/terminal.py
  34. 4 0
      meta/lib/oe/types.py
  35. 3 0
      meta/lib/oe/useradd.py
  36. 4 0
      meta/lib/oe/utils.py
  37. 1 7
      meta/lib/oeqa/buildperf/__init__.py
  38. 1 8
      meta/lib/oeqa/buildperf/base.py
  39. 1 8
      meta/lib/oeqa/buildperf/test_basic.py
  40. 3 0
      meta/lib/oeqa/controllers/__init__.py
  41. 2 2
      meta/lib/oeqa/controllers/masterimage.py
  42. 4 0
      meta/lib/oeqa/controllers/testtargetloader.py
  43. 4 1
      meta/lib/oeqa/core/case.py
  44. 3 1
      meta/lib/oeqa/core/cases/example/test_basic.py
  45. 4 2
      meta/lib/oeqa/core/context.py
  46. 4 1
      meta/lib/oeqa/core/decorator/__init__.py
  47. 4 1
      meta/lib/oeqa/core/decorator/data.py
  48. 4 1
      meta/lib/oeqa/core/decorator/depends.py
  49. 4 1
      meta/lib/oeqa/core/decorator/oetag.py
  50. 4 1
      meta/lib/oeqa/core/decorator/oetimeout.py
  51. 4 1
      meta/lib/oeqa/core/exception.py
  52. 4 1
      meta/lib/oeqa/core/loader.py
  53. 4 1
      meta/lib/oeqa/core/runner.py
  54. 4 1
      meta/lib/oeqa/core/target/__init__.py
  55. 4 1
      meta/lib/oeqa/core/target/qemu.py
  56. 4 1
      meta/lib/oeqa/core/target/ssh.py
  57. 4 1
      meta/lib/oeqa/core/tests/cases/data.py
  58. 4 1
      meta/lib/oeqa/core/tests/cases/depends.py
  59. 4 1
      meta/lib/oeqa/core/tests/cases/loader/valid/another.py
  60. 4 1
      meta/lib/oeqa/core/tests/cases/oetag.py
  61. 4 1
      meta/lib/oeqa/core/tests/cases/timeout.py
  62. 4 1
      meta/lib/oeqa/core/tests/common.py
  63. 3 1
      meta/lib/oeqa/core/tests/test_data.py
  64. 4 2
      meta/lib/oeqa/core/tests/test_decorators.py
  65. 4 2
      meta/lib/oeqa/core/tests/test_loader.py
  66. 4 2
      meta/lib/oeqa/core/tests/test_runner.py
  67. 2 0
      meta/lib/oeqa/core/utils/concurrencytest.py
  68. 4 1
      meta/lib/oeqa/core/utils/misc.py
  69. 4 1
      meta/lib/oeqa/core/utils/path.py
  70. 4 1
      meta/lib/oeqa/core/utils/test.py
  71. 3 1
      meta/lib/oeqa/oetest.py
  72. 3 3
      meta/lib/oeqa/runexported.py
  73. 4 1
      meta/lib/oeqa/runtime/case.py
  74. 4 0
      meta/lib/oeqa/runtime/cases/_qemutiny.py
  75. 4 0
      meta/lib/oeqa/runtime/cases/apt.py
  76. 4 0
      meta/lib/oeqa/runtime/cases/buildcpio.py
  77. 4 0
      meta/lib/oeqa/runtime/cases/buildgalculator.py
  78. 4 0
      meta/lib/oeqa/runtime/cases/buildlzip.py
  79. 4 0
      meta/lib/oeqa/runtime/cases/connman.py
  80. 4 0
      meta/lib/oeqa/runtime/cases/date.py
  81. 4 0
      meta/lib/oeqa/runtime/cases/df.py
  82. 4 0
      meta/lib/oeqa/runtime/cases/dnf.py
  83. 4 0
      meta/lib/oeqa/runtime/cases/gcc.py
  84. 4 0
      meta/lib/oeqa/runtime/cases/gi.py
  85. 4 0
      meta/lib/oeqa/runtime/cases/gstreamer.py
  86. 4 0
      meta/lib/oeqa/runtime/cases/kernelmodule.py
  87. 4 0
      meta/lib/oeqa/runtime/cases/ksample.py
  88. 4 0
      meta/lib/oeqa/runtime/cases/ldd.py
  89. 4 0
      meta/lib/oeqa/runtime/cases/logrotate.py
  90. 2 8
      meta/lib/oeqa/runtime/cases/ltp.py
  91. 1 8
      meta/lib/oeqa/runtime/cases/ltp_compliance.py
  92. 4 0
      meta/lib/oeqa/runtime/cases/multilib.py
  93. 4 0
      meta/lib/oeqa/runtime/cases/oe_syslog.py
  94. 4 0
      meta/lib/oeqa/runtime/cases/opkg.py
  95. 4 0
      meta/lib/oeqa/runtime/cases/pam.py
  96. 4 0
      meta/lib/oeqa/runtime/cases/parselogs.py
  97. 4 0
      meta/lib/oeqa/runtime/cases/perl.py
  98. 4 0
      meta/lib/oeqa/runtime/cases/ping.py
  99. 4 0
      meta/lib/oeqa/runtime/cases/ptest.py
  100. 4 0
      meta/lib/oeqa/runtime/cases/python.py

+ 15 - 9
LICENSE

@@ -1,14 +1,20 @@
 Different components of OpenEmbedded are under different licenses (a mix
-of MIT and GPLv2). Please see:
-
-meta/COPYING.GPLv2 (GPLv2)
-meta/COPYING.MIT (MIT)
-meta-selftest/COPYING.MIT (MIT)
-meta-skeleton/COPYING.MIT (MIT)
+of MIT and GPLv2). See LICENSE.GPL-2.0-only and LICENSE.MIT for further 
+details of the individual licenses.
 
 All metadata is MIT licensed unless otherwise stated. Source code
-included in tree for individual recipes is under the LICENSE stated in
-the associated recipe (.bb file) unless otherwise stated.
+included in tree for individual recipes (e.g. patches) are under 
+the LICENSE stated in the associated recipe (.bb file) unless 
+otherwise stated.
 
 License information for any other files is either explicitly stated 
-or defaults to GPL version 2.
+or defaults to GPL version 2 only.
+
+Individual files contain the following style tags instead of the full license 
+text to identify their license:
+
+    SPDX-License-Identifier: GPL-2.0-only
+    SPDX-License-Identifier: MIT
+
+This enables machine processing of license information based on the SPDX
+License Identifiers that are here available: http://spdx.org/licenses/

+ 5 - 56
meta/COPYING.GPLv2 → LICENSE.GPL-2.0-only

@@ -279,61 +279,10 @@ POSSIBILITY OF SUCH DAMAGES.
 
 		     END OF TERMS AND CONDITIONS
 
-	    How to Apply These Terms to Your New Programs
+Note:
+Individual files contain the following tag instead of the full license text.
 
-  If you develop a new program, and you want it to be of the greatest
-possible use to the public, the best way to achieve this is to make it
-free software which everyone can redistribute and change under these terms.
+    SPDX-License-Identifier: GPL-2.0-only
 
-  To do so, attach the following notices to the program.  It is safest
-to attach them to the start of each source file to most effectively
-convey the exclusion of warranty; and each file should have at least
-the "copyright" line and a pointer to where the full notice is found.
-
-    <one line to give the program's name and a brief idea of what it does.>
-    Copyright (C) <year>  <name of author>
-
-    This program is free software; you can redistribute it and/or modify
-    it under the terms of the GNU General Public License as published by
-    the Free Software Foundation; either version 2 of the License, or
-    (at your option) any later version.
-
-    This program is distributed in the hope that it will be useful,
-    but WITHOUT ANY WARRANTY; without even the implied warranty of
-    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-    GNU General Public License for more details.
-
-    You should have received a copy of the GNU General Public License along
-    with this program; if not, write to the Free Software Foundation, Inc.,
-    51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
-
-Also add information on how to contact you by electronic and paper mail.
-
-If the program is interactive, make it output a short notice like this
-when it starts in an interactive mode:
-
-    Gnomovision version 69, Copyright (C) year name of author
-    Gnomovision comes with ABSOLUTELY NO WARRANTY; for details type `show w'.
-    This is free software, and you are welcome to redistribute it
-    under certain conditions; type `show c' for details.
-
-The hypothetical commands `show w' and `show c' should show the appropriate
-parts of the General Public License.  Of course, the commands you use may
-be called something other than `show w' and `show c'; they could even be
-mouse-clicks or menu items--whatever suits your program.
-
-You should also get your employer (if you work as a programmer) or your
-school, if any, to sign a "copyright disclaimer" for the program, if
-necessary.  Here is a sample; alter the names:
-
-  Yoyodyne, Inc., hereby disclaims all copyright interest in the program
-  `Gnomovision' (which makes passes at compilers) written by James Hacker.
-
-  <signature of Ty Coon>, 1 April 1989
-  Ty Coon, President of Vice
-
-This General Public License does not permit incorporating your program into
-proprietary programs.  If your program is a subroutine library, you may
-consider it more useful to permit linking proprietary applications with the
-library.  If this is what you want to do, use the GNU Lesser General
-Public License instead of this License.
+This enables machine processing of license information based on the SPDX
+License Identifiers that are here available: http://spdx.org/licenses/

+ 10 - 2
meta-selftest/COPYING.MIT → LICENSE.MIT

@@ -13,5 +13,13 @@ IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
 FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
 AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
 LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
-OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
-THE SOFTWARE.
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
+
+Note:
+Individual files contain the following tag instead of the full license text.
+
+    SPDX-License-Identifier: MIT
+
+This enables machine processing of license information based on the SPDX
+License Identifiers that are here available: http://spdx.org/licenses/

+ 0 - 17
meta-skeleton/COPYING.MIT

@@ -1,17 +0,0 @@
-Permission is hereby granted, free of charge, to any person obtaining a copy 
-of this software and associated documentation files (the "Software"), to deal 
-in the Software without restriction, including without limitation the rights 
-to use, copy, modify, merge, publish, distribute, sublicense, and/or sell 
-copies of the Software, and to permit persons to whom the Software is 
-furnished to do so, subject to the following conditions:
-
-The above copyright notice and this permission notice shall be included in 
-all copies or substantial portions of the Software.
-
-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR 
-IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, 
-FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE 
-AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER 
-LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, 
-OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN 
-THE SOFTWARE.

+ 4 - 0
meta/lib/bblayers/create.py

@@ -1,3 +1,7 @@
+#
+# SPDX-License-Identifier: GPL-2.0-only
+#
+
 import logging
 import os
 import sys

+ 3 - 0
meta/lib/buildstats.py

@@ -1,3 +1,6 @@
+#
+# SPDX-License-Identifier: GPL-2.0-only
+#
 # Implements system state sampling. Called by buildstats.bbclass.
 # Because it is a real Python module, it can hold persistent state,
 # like open log files and the time of the last sampling.

+ 4 - 0
meta/lib/oe/__init__.py

@@ -1,2 +1,6 @@
+#
+# SPDX-License-Identifier: GPL-2.0-only
+#
+
 from pkgutil import extend_path
 __path__ = extend_path(__path__, __name__)

+ 2 - 0
meta/lib/oe/buildhistory_analysis.py

@@ -3,6 +3,8 @@
 # Copyright (C) 2012-2013, 2016-2017 Intel Corporation
 # Author: Paul Eggleton <paul.eggleton@linux.intel.com>
 #
+# SPDX-License-Identifier: GPL-2.0-only
+#
 # Note: requires GitPython 0.3.1+
 #
 # You can use this from the command line by running scripts/buildhistory-diff

+ 2 - 0
meta/lib/oe/cachedpath.py

@@ -1,4 +1,6 @@
 #
+# SPDX-License-Identifier: GPL-2.0-only
+#
 # Based on standard python library functions but avoid
 # repeated stat calls. Its assumed the files will not change from under us
 # so we can cache stat calls.

+ 4 - 0
meta/lib/oe/classextend.py

@@ -1,3 +1,7 @@
+#
+# SPDX-License-Identifier: GPL-2.0-only
+#
+
 import collections
 
 class ClassExtender(object):

+ 3 - 0
meta/lib/oe/classutils.py

@@ -1,3 +1,6 @@
+#
+# SPDX-License-Identifier: GPL-2.0-only
+#
 
 class ClassRegistryMeta(type):
     """Give each ClassRegistry their own registry"""

+ 3 - 0
meta/lib/oe/copy_buildsystem.py

@@ -1,3 +1,6 @@
+#
+# SPDX-License-Identifier: GPL-2.0-only
+#
 # This class should provide easy access to the different aspects of the
 # buildsystem such as layers, bitbake location, etc.
 #

+ 4 - 0
meta/lib/oe/data.py

@@ -1,3 +1,7 @@
+#
+# SPDX-License-Identifier: GPL-2.0-only
+#
+
 import json
 import oe.maketype
 

+ 4 - 0
meta/lib/oe/distro_check.py

@@ -1,3 +1,7 @@
+#
+# SPDX-License-Identifier: GPL-2.0-only
+#
+
 def create_socket(url, d):
     import urllib
     from bb.utils import export_proxies

+ 4 - 0
meta/lib/oe/elf.py

@@ -1,3 +1,7 @@
+#
+# SPDX-License-Identifier: GPL-2.0-only
+#
+
 def machine_dict(d):
 #           TARGET_OS  TARGET_ARCH   MACHINE, OSABI, ABIVERSION, Little Endian, 32bit?
     machdata = {

+ 4 - 0
meta/lib/oe/gpg_sign.py

@@ -1,3 +1,7 @@
+#
+# SPDX-License-Identifier: GPL-2.0-only
+#
+
 """Helper module for GPG signing"""
 import os
 

+ 3 - 1
meta/lib/oe/license.py

@@ -1,4 +1,6 @@
-# vi:sts=4:sw=4:et
+#
+# SPDX-License-Identifier: GPL-2.0-only
+#
 """Code for parsing OpenEmbedded license strings"""
 
 import ast

+ 4 - 0
meta/lib/oe/lsb.py

@@ -1,3 +1,7 @@
+#
+# SPDX-License-Identifier: GPL-2.0-only
+#
+
 def get_os_release():
     """Get all key-value pairs from /etc/os-release as a dict"""
     from collections import OrderedDict

+ 3 - 0
meta/lib/oe/maketype.py

@@ -1,3 +1,6 @@
+#
+# SPDX-License-Identifier: GPL-2.0-only
+#
 """OpenEmbedded variable typing support
 
 Types are defined in the metadata by name, using the 'type' flag on a

+ 4 - 0
meta/lib/oe/manifest.py

@@ -1,3 +1,7 @@
+#
+# SPDX-License-Identifier: GPL-2.0-only
+#
+
 from abc import ABCMeta, abstractmethod
 import os
 import re

+ 4 - 0
meta/lib/oe/package.py

@@ -1,3 +1,7 @@
+#
+# SPDX-License-Identifier: GPL-2.0-only
+#
+
 import stat
 import mmap
 import subprocess

+ 4 - 0
meta/lib/oe/package_manager.py

@@ -1,3 +1,7 @@
+#
+# SPDX-License-Identifier: GPL-2.0-only
+#
+
 from abc import ABCMeta, abstractmethod
 import os
 import glob

+ 4 - 0
meta/lib/oe/packagedata.py

@@ -1,3 +1,7 @@
+#
+# SPDX-License-Identifier: GPL-2.0-only
+#
+
 import codecs
 import os
 

+ 4 - 0
meta/lib/oe/packagegroup.py

@@ -1,3 +1,7 @@
+#
+# SPDX-License-Identifier: GPL-2.0-only
+#
+
 import itertools
 
 def is_optional(feature, d):

+ 4 - 0
meta/lib/oe/patch.py

@@ -1,3 +1,7 @@
+#
+# SPDX-License-Identifier: GPL-2.0-only
+#
+
 import oe.path
 import oe.types
 

+ 4 - 0
meta/lib/oe/path.py

@@ -1,3 +1,7 @@
+#
+# SPDX-License-Identifier: GPL-2.0-only
+#
+
 import errno
 import glob
 import shutil

+ 3 - 0
meta/lib/oe/prservice.py

@@ -1,3 +1,6 @@
+#
+# SPDX-License-Identifier: GPL-2.0-only
+#
 
 def prserv_make_conn(d, check = False):
     import prserv.serv

+ 4 - 0
meta/lib/oe/qa.py

@@ -1,3 +1,7 @@
+#
+# SPDX-License-Identifier: GPL-2.0-only
+#
+
 import os, struct, mmap
 
 class NotELFFileError(Exception):

+ 2 - 0
meta/lib/oe/recipeutils.py

@@ -4,6 +4,8 @@
 #
 # Copyright (C) 2013-2017 Intel Corporation
 #
+# SPDX-License-Identifier: GPL-2.0-only
+#
 
 import sys
 import os

+ 3 - 0
meta/lib/oe/rootfs.py

@@ -1,3 +1,6 @@
+#
+# SPDX-License-Identifier: GPL-2.0-only
+#
 from abc import ABCMeta, abstractmethod
 from oe.utils import execute_pre_post_process
 from oe.package_manager import *

+ 4 - 0
meta/lib/oe/sdk.py

@@ -1,3 +1,7 @@
+#
+# SPDX-License-Identifier: GPL-2.0-only
+#
+
 from abc import ABCMeta, abstractmethod
 from oe.utils import execute_pre_post_process
 from oe.manifest import *

+ 3 - 0
meta/lib/oe/sstatesig.py

@@ -1,3 +1,6 @@
+#
+# SPDX-License-Identifier: GPL-2.0-only
+#
 import bb.siggen
 import oe
 

+ 3 - 0
meta/lib/oe/terminal.py

@@ -1,3 +1,6 @@
+#
+# SPDX-License-Identifier: GPL-2.0-only
+#
 import logging
 import oe.classutils
 import shlex

+ 4 - 0
meta/lib/oe/types.py

@@ -1,3 +1,7 @@
+#
+# SPDX-License-Identifier: GPL-2.0-only
+#
+
 import errno
 import re
 import os

+ 3 - 0
meta/lib/oe/useradd.py

@@ -1,3 +1,6 @@
+#
+# SPDX-License-Identifier: GPL-2.0-only
+#
 import argparse
 import re
 

+ 4 - 0
meta/lib/oe/utils.py

@@ -1,3 +1,7 @@
+#
+# SPDX-License-Identifier: GPL-2.0-only
+#
+
 import subprocess
 import multiprocessing
 import traceback

+ 1 - 7
meta/lib/oeqa/buildperf/__init__.py

@@ -1,13 +1,7 @@
 # Copyright (c) 2016, Intel Corporation.
 #
-# This program is free software; you can redistribute it and/or modify it
-# under the terms and conditions of the GNU General Public License,
-# version 2, as published by the Free Software Foundation.
 #
-# This program is distributed in the hope it will be useful, but WITHOUT
-# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
-# FITNESS FOR A PARTICULAR PURPOSE.  See the GNU General Public License for
-# more details.
+# SPDX-License-Identifier: GPL-2.0-only
 #
 """Build performance tests"""
 from .base import (BuildPerfTestCase,

+ 1 - 8
meta/lib/oeqa/buildperf/base.py

@@ -1,13 +1,6 @@
 # Copyright (c) 2016, Intel Corporation.
 #
-# This program is free software; you can redistribute it and/or modify it
-# under the terms and conditions of the GNU General Public License,
-# version 2, as published by the Free Software Foundation.
-#
-# This program is distributed in the hope it will be useful, but WITHOUT
-# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
-# FITNESS FOR A PARTICULAR PURPOSE.  See the GNU General Public License for
-# more details.
+# SPDX-License-Identifier: GPL-2.0-only
 #
 """Build performance test base classes and functionality"""
 import json

+ 1 - 8
meta/lib/oeqa/buildperf/test_basic.py

@@ -1,13 +1,6 @@
 # Copyright (c) 2016, Intel Corporation.
 #
-# This program is free software; you can redistribute it and/or modify it
-# under the terms and conditions of the GNU General Public License,
-# version 2, as published by the Free Software Foundation.
-#
-# This program is distributed in the hope it will be useful, but WITHOUT
-# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
-# FITNESS FOR A PARTICULAR PURPOSE.  See the GNU General Public License for
-# more details.
+# SPDX-License-Identifier: GPL-2.0-only
 #
 """Basic set of build performance tests"""
 import os

+ 3 - 0
meta/lib/oeqa/controllers/__init__.py

@@ -1,3 +1,6 @@
+#
+# SPDX-License-Identifier: GPL-2.0-only
+#
 # Enable other layers to have modules in the same named directory
 from pkgutil import extend_path
 __path__ = extend_path(__path__, __name__)

+ 2 - 2
meta/lib/oeqa/controllers/masterimage.py

@@ -1,7 +1,7 @@
 # Copyright (C) 2014 Intel Corporation
 #
-# Released under the MIT license (see COPYING.MIT)
-
+# SPDX-License-Identifier: MIT
+#
 # This module adds support to testimage.bbclass to deploy images and run
 # tests using a "master image" - this is a "known good" image that is
 # installed onto the device as part of initial setup and will be booted into

+ 4 - 0
meta/lib/oeqa/controllers/testtargetloader.py

@@ -1,3 +1,7 @@
+#
+# SPDX-License-Identifier: GPL-2.0-only
+#
+
 import types
 import bb
 import os

+ 4 - 1
meta/lib/oeqa/core/case.py

@@ -1,5 +1,8 @@
+#
 # Copyright (C) 2016 Intel Corporation
-# Released under the MIT license (see COPYING.MIT)
+#
+# SPDX-License-Identifier: MIT
+#
 
 import unittest
 

+ 3 - 1
meta/lib/oeqa/core/cases/example/test_basic.py

@@ -1,5 +1,7 @@
 # Copyright (C) 2016 Intel Corporation
-# Released under the MIT license (see COPYING.MIT)
+#
+# SPDX-License-Identifier: MIT
+#
 
 from oeqa.core.case import OETestCase
 from oeqa.core.decorator.depends import OETestDepends

+ 4 - 2
meta/lib/oeqa/core/context.py

@@ -1,5 +1,7 @@
-# Copyright (C) 2016 Intel Corporation
-# Released under the MIT license (see COPYING.MIT)
+## Copyright (C) 2016 Intel Corporation
+#
+# SPDX-License-Identifier: MIT
+#
 
 import os
 import sys

+ 4 - 1
meta/lib/oeqa/core/decorator/__init__.py

@@ -1,5 +1,8 @@
+#
 # Copyright (C) 2016 Intel Corporation
-# Released under the MIT license (see COPYING.MIT)
+#
+# SPDX-License-Identifier: MIT
+#
 
 from functools import wraps
 from abc import abstractmethod, ABCMeta

+ 4 - 1
meta/lib/oeqa/core/decorator/data.py

@@ -1,5 +1,8 @@
+#
 # Copyright (C) 2016 Intel Corporation
-# Released under the MIT license (see COPYING.MIT)
+#
+# SPDX-License-Identifier: MIT
+#
 
 from oeqa.core.exception import OEQAMissingVariable
 

+ 4 - 1
meta/lib/oeqa/core/decorator/depends.py

@@ -1,5 +1,8 @@
+#
 # Copyright (C) 2016 Intel Corporation
-# Released under the MIT license (see COPYING.MIT)
+#
+# SPDX-License-Identifier: MIT
+#
 
 from unittest import SkipTest
 

+ 4 - 1
meta/lib/oeqa/core/decorator/oetag.py

@@ -1,5 +1,8 @@
+#
 # Copyright (C) 2016 Intel Corporation
-# Released under the MIT license (see COPYING.MIT)
+#
+# SPDX-License-Identifier: MIT
+#
 
 from . import OETestFilter, registerDecorator
 from oeqa.core.utils.misc import strToList

+ 4 - 1
meta/lib/oeqa/core/decorator/oetimeout.py

@@ -1,5 +1,8 @@
+#
 # Copyright (C) 2016 Intel Corporation
-# Released under the MIT license (see COPYING.MIT)
+#
+# SPDX-License-Identifier: MIT
+#
 
 import signal
 from . import OETestDecorator, registerDecorator

+ 4 - 1
meta/lib/oeqa/core/exception.py

@@ -1,5 +1,8 @@
+#
 # Copyright (C) 2016 Intel Corporation
-# Released under the MIT license (see COPYING.MIT)
+#
+# SPDX-License-Identifier: MIT
+#
 
 class OEQAException(Exception):
     pass

+ 4 - 1
meta/lib/oeqa/core/loader.py

@@ -1,5 +1,8 @@
+#
 # Copyright (C) 2016 Intel Corporation
-# Released under the MIT license (see COPYING.MIT)
+#
+# SPDX-License-Identifier: MIT
+#
 
 import os
 import re

+ 4 - 1
meta/lib/oeqa/core/runner.py

@@ -1,5 +1,8 @@
+#
 # Copyright (C) 2016 Intel Corporation
-# Released under the MIT license (see COPYING.MIT)
+#
+# SPDX-License-Identifier: MIT
+#
 
 import os
 import time

+ 4 - 1
meta/lib/oeqa/core/target/__init__.py

@@ -1,5 +1,8 @@
+#
 # Copyright (C) 2016 Intel Corporation
-# Released under the MIT license (see COPYING.MIT)
+#
+# SPDX-License-Identifier: MIT
+#
 
 from abc import abstractmethod
 

+ 4 - 1
meta/lib/oeqa/core/target/qemu.py

@@ -1,5 +1,8 @@
+#
 # Copyright (C) 2016 Intel Corporation
-# Released under the MIT license (see COPYING.MIT)
+#
+# SPDX-License-Identifier: MIT
+#
 
 import os
 import sys

+ 4 - 1
meta/lib/oeqa/core/target/ssh.py

@@ -1,5 +1,8 @@
+#
 # Copyright (C) 2016 Intel Corporation
-# Released under the MIT license (see COPYING.MIT)
+#
+# SPDX-License-Identifier: MIT
+#
 
 import os
 import time

+ 4 - 1
meta/lib/oeqa/core/tests/cases/data.py

@@ -1,5 +1,8 @@
+#
 # Copyright (C) 2016 Intel Corporation
-# Released under the MIT license (see COPYING.MIT)
+#
+# SPDX-License-Identifier: MIT
+#
 
 from oeqa.core.case import OETestCase
 from oeqa.core.decorator.oetag import OETestTag

+ 4 - 1
meta/lib/oeqa/core/tests/cases/depends.py

@@ -1,5 +1,8 @@
+#
 # Copyright (C) 2016 Intel Corporation
-# Released under the MIT license (see COPYING.MIT)
+#
+# SPDX-License-Identifier: MIT
+#
 
 from oeqa.core.case import OETestCase
 from oeqa.core.decorator.depends import OETestDepends

+ 4 - 1
meta/lib/oeqa/core/tests/cases/loader/valid/another.py

@@ -1,5 +1,8 @@
+#
 # Copyright (C) 2016 Intel Corporation
-# Released under the MIT license (see COPYING.MIT)
+#
+# SPDX-License-Identifier: MIT
+#
 
 from oeqa.core.case import OETestCase
 

+ 4 - 1
meta/lib/oeqa/core/tests/cases/oetag.py

@@ -1,5 +1,8 @@
+#
 # Copyright (C) 2016 Intel Corporation
-# Released under the MIT license (see COPYING.MIT)
+#
+# SPDX-License-Identifier: MIT
+#
 
 from oeqa.core.case import OETestCase
 from oeqa.core.decorator.oetag import OETestTag

+ 4 - 1
meta/lib/oeqa/core/tests/cases/timeout.py

@@ -1,5 +1,8 @@
+#
 # Copyright (C) 2016 Intel Corporation
-# Released under the MIT license (see COPYING.MIT)
+#
+# SPDX-License-Identifier: MIT
+#
 
 from time import sleep
 

+ 4 - 1
meta/lib/oeqa/core/tests/common.py

@@ -1,5 +1,8 @@
+#
 # Copyright (C) 2016 Intel Corporation
-# Released under the MIT license (see COPYING.MIT)
+#
+# SPDX-License-Identifier: MIT
+#
 
 import sys
 import os

+ 3 - 1
meta/lib/oeqa/core/tests/test_data.py

@@ -1,7 +1,9 @@
 #!/usr/bin/env python3
 
 # Copyright (C) 2016 Intel Corporation
-# Released under the MIT license (see COPYING.MIT)
+#
+# SPDX-License-Identifier: MIT
+#
 
 import unittest
 import logging

+ 4 - 2
meta/lib/oeqa/core/tests/test_decorators.py

@@ -1,7 +1,9 @@
 #!/usr/bin/env python3
-
+#
 # Copyright (C) 2016 Intel Corporation
-# Released under the MIT license (see COPYING.MIT)
+#
+# SPDX-License-Identifier: MIT
+#
 
 import signal
 import unittest

+ 4 - 2
meta/lib/oeqa/core/tests/test_loader.py

@@ -1,7 +1,9 @@
 #!/usr/bin/env python3
-
+#
 # Copyright (C) 2016 Intel Corporation
-# Released under the MIT license (see COPYING.MIT)
+#
+# SPDX-License-Identifier: MIT
+#
 
 import os
 import unittest

+ 4 - 2
meta/lib/oeqa/core/tests/test_runner.py

@@ -1,7 +1,9 @@
 #!/usr/bin/env python3
-
+#
 # Copyright (C) 2016 Intel Corporation
-# Released under the MIT license (see COPYING.MIT)
+#
+# SPDX-License-Identifier: MIT
+#
 
 import unittest
 import logging

+ 2 - 0
meta/lib/oeqa/core/utils/concurrencytest.py

@@ -1,5 +1,7 @@
 #!/usr/bin/env python3
 #
+# SPDX-License-Identifier: GPL-2.0-or-later
+#
 # Modified for use in OE by Richard Purdie, 2018
 #
 # Modified by: Corey Goldberg, 2013

+ 4 - 1
meta/lib/oeqa/core/utils/misc.py

@@ -1,5 +1,8 @@
+#
 # Copyright (C) 2016 Intel Corporation
-# Released under the MIT license (see COPYING.MIT)
+#
+# SPDX-License-Identifier: MIT
+#
 
 def toList(obj, obj_type, obj_name="Object"):
     if isinstance(obj, obj_type):

+ 4 - 1
meta/lib/oeqa/core/utils/path.py

@@ -1,5 +1,8 @@
+#
 # Copyright (C) 2016 Intel Corporation
-# Released under the MIT license (see COPYING.MIT)
+#
+# SPDX-License-Identifier: MIT
+#
 
 import os
 import sys

+ 4 - 1
meta/lib/oeqa/core/utils/test.py

@@ -1,5 +1,8 @@
+#
 # Copyright (C) 2016 Intel Corporation
-# Released under the MIT license (see COPYING.MIT)
+#
+# SPDX-License-Identifier: MIT
+#
 
 import os
 import inspect

+ 3 - 1
meta/lib/oeqa/oetest.py

@@ -1,6 +1,8 @@
+#
 # Copyright (C) 2013 Intel Corporation
 #
-# Released under the MIT license (see COPYING.MIT)
+# SPDX-License-Identifier: MIT
+#
 
 # Main unittest module used by testimage.bbclass
 # This provides the oeRuntimeTest base class which is inherited by all tests in meta/lib/oeqa/runtime.

+ 3 - 3
meta/lib/oeqa/runexported.py

@@ -1,9 +1,9 @@
 #!/usr/bin/env python3
-
-
+#
 # Copyright (C) 2013 Intel Corporation
 #
-# Released under the MIT license (see COPYING.MIT)
+# SPDX-License-Identifier: MIT
+#
 
 # This script should be used outside of the build system to run image tests.
 # It needs a json file as input as exported by the build.

+ 4 - 1
meta/lib/oeqa/runtime/case.py

@@ -1,5 +1,8 @@
+#
 # Copyright (C) 2016 Intel Corporation
-# Released under the MIT license (see COPYING.MIT)
+#
+# SPDX-License-Identifier: MIT
+#
 
 from oeqa.core.case import OETestCase
 from oeqa.utils.package_manager import install_package, uninstall_package

+ 4 - 0
meta/lib/oeqa/runtime/cases/_qemutiny.py

@@ -1,3 +1,7 @@
+#
+# SPDX-License-Identifier: MIT
+#
+
 from oeqa.runtime.case import OERuntimeTestCase
 
 class QemuTinyTest(OERuntimeTestCase):

+ 4 - 0
meta/lib/oeqa/runtime/cases/apt.py

@@ -1,3 +1,7 @@
+#
+# SPDX-License-Identifier: MIT
+#
+
 import os
 from oeqa.utils.httpserver import HTTPService
 from oeqa.runtime.case import OERuntimeTestCase

+ 4 - 0
meta/lib/oeqa/runtime/cases/buildcpio.py

@@ -1,3 +1,7 @@
+#
+# SPDX-License-Identifier: MIT
+#
+
 from oeqa.runtime.case import OERuntimeTestCase
 from oeqa.core.decorator.depends import OETestDepends
 from oeqa.runtime.decorator.package import OEHasPackage

+ 4 - 0
meta/lib/oeqa/runtime/cases/buildgalculator.py

@@ -1,3 +1,7 @@
+#
+# SPDX-License-Identifier: MIT
+#
+
 from oeqa.runtime.case import OERuntimeTestCase
 from oeqa.core.decorator.depends import OETestDepends
 from oeqa.runtime.decorator.package import OEHasPackage

+ 4 - 0
meta/lib/oeqa/runtime/cases/buildlzip.py

@@ -1,3 +1,7 @@
+#
+# SPDX-License-Identifier: MIT
+#
+
 from oeqa.runtime.case import OERuntimeTestCase
 from oeqa.core.decorator.depends import OETestDepends
 from oeqa.runtime.decorator.package import OEHasPackage

+ 4 - 0
meta/lib/oeqa/runtime/cases/connman.py

@@ -1,3 +1,7 @@
+#
+# SPDX-License-Identifier: MIT
+#
+
 from oeqa.runtime.case import OERuntimeTestCase
 from oeqa.core.decorator.depends import OETestDepends
 from oeqa.runtime.decorator.package import OEHasPackage

+ 4 - 0
meta/lib/oeqa/runtime/cases/date.py

@@ -1,3 +1,7 @@
+#
+# SPDX-License-Identifier: MIT
+#
+
 import re
 
 from oeqa.runtime.case import OERuntimeTestCase

+ 4 - 0
meta/lib/oeqa/runtime/cases/df.py

@@ -1,3 +1,7 @@
+#
+# SPDX-License-Identifier: MIT
+#
+
 from oeqa.runtime.case import OERuntimeTestCase
 from oeqa.core.decorator.depends import OETestDepends
 from oeqa.runtime.decorator.package import OEHasPackage

+ 4 - 0
meta/lib/oeqa/runtime/cases/dnf.py

@@ -1,3 +1,7 @@
+#
+# SPDX-License-Identifier: MIT
+#
+
 import os
 import re
 import subprocess

+ 4 - 0
meta/lib/oeqa/runtime/cases/gcc.py

@@ -1,3 +1,7 @@
+#
+# SPDX-License-Identifier: MIT
+#
+
 import os
 
 from oeqa.runtime.case import OERuntimeTestCase

+ 4 - 0
meta/lib/oeqa/runtime/cases/gi.py

@@ -1,3 +1,7 @@
+#
+# SPDX-License-Identifier: MIT
+#
+
 import os
 
 from oeqa.runtime.case import OERuntimeTestCase

+ 4 - 0
meta/lib/oeqa/runtime/cases/gstreamer.py

@@ -1,3 +1,7 @@
+#
+# SPDX-License-Identifier: MIT
+#
+
 from oeqa.runtime.case import OERuntimeTestCase
 from oeqa.runtime.decorator.package import OEHasPackage
 

+ 4 - 0
meta/lib/oeqa/runtime/cases/kernelmodule.py

@@ -1,3 +1,7 @@
+#
+# SPDX-License-Identifier: MIT
+#
+
 import os
 
 from oeqa.runtime.case import OERuntimeTestCase

+ 4 - 0
meta/lib/oeqa/runtime/cases/ksample.py

@@ -1,3 +1,7 @@
+#
+# SPDX-License-Identifier: MIT
+#
+
 import os
 import time
 

+ 4 - 0
meta/lib/oeqa/runtime/cases/ldd.py

@@ -1,3 +1,7 @@
+#
+# SPDX-License-Identifier: MIT
+#
+
 from oeqa.runtime.case import OERuntimeTestCase
 from oeqa.core.decorator.depends import OETestDepends
 from oeqa.core.decorator.data import skipIfNotFeature

+ 4 - 0
meta/lib/oeqa/runtime/cases/logrotate.py

@@ -1,3 +1,7 @@
+#
+# SPDX-License-Identifier: MIT
+#
+
 # This test should cover https://bugzilla.yoctoproject.org/tr_show_case.cgi?case_id=289 testcase
 # Note that the image under test must have logrotate installed
 

+ 2 - 8
meta/lib/oeqa/runtime/cases/ltp.py

@@ -2,15 +2,9 @@
 #
 # Copyright (c) 2019 MontaVista Software, LLC
 #
-# This program is free software; you can redistribute it and/or modify it
-# under the terms and conditions of the GNU General Public License,
-# version 2, as published by the Free Software Foundation.
-#
-# This program is distributed in the hope it will be useful, but WITHOUT
-# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
-# FITNESS FOR A PARTICULAR PURPOSE.  See the GNU General Public License for
-# more details.
+# SPDX-License-Identifier: GPL-2.0-only
 #
+
 import time
 import datetime
 import pprint

+ 1 - 8
meta/lib/oeqa/runtime/cases/ltp_compliance.py

@@ -2,14 +2,7 @@
 #
 # Copyright (c) 2019 MontaVista Software, LLC
 #
-# This program is free software; you can redistribute it and/or modify it
-# under the terms and conditions of the GNU General Public License,
-# version 2, as published by the Free Software Foundation.
-#
-# This program is distributed in the hope it will be useful, but WITHOUT
-# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
-# FITNESS FOR A PARTICULAR PURPOSE.  See the GNU General Public License for
-# more details.
+# SPDX-License-Identifier: GPL-2.0-only
 #
 
 import time

+ 4 - 0
meta/lib/oeqa/runtime/cases/multilib.py

@@ -1,3 +1,7 @@
+#
+# SPDX-License-Identifier: MIT
+#
+
 from oeqa.runtime.case import OERuntimeTestCase
 from oeqa.core.decorator.depends import OETestDepends
 from oeqa.core.decorator.data import skipIfNotInDataVar

+ 4 - 0
meta/lib/oeqa/runtime/cases/oe_syslog.py

@@ -1,3 +1,7 @@
+#
+# SPDX-License-Identifier: MIT
+#
+
 from oeqa.runtime.case import OERuntimeTestCase
 from oeqa.core.decorator.depends import OETestDepends
 from oeqa.core.decorator.data import skipIfDataVar

+ 4 - 0
meta/lib/oeqa/runtime/cases/opkg.py

@@ -1,3 +1,7 @@
+#
+# SPDX-License-Identifier: MIT
+#
+
 import os
 from oeqa.utils.httpserver import HTTPService
 from oeqa.runtime.case import OERuntimeTestCase

+ 4 - 0
meta/lib/oeqa/runtime/cases/pam.py

@@ -1,3 +1,7 @@
+#
+# SPDX-License-Identifier: MIT
+#
+
 # This test should cover https://bugzilla.yoctoproject.org/tr_show_case.cgi?case_id=287 testcase
 # Note that the image under test must have "pam" in DISTRO_FEATURES
 

+ 4 - 0
meta/lib/oeqa/runtime/cases/parselogs.py

@@ -1,3 +1,7 @@
+#
+# SPDX-License-Identifier: MIT
+#
+
 import os
 
 from subprocess import check_output

+ 4 - 0
meta/lib/oeqa/runtime/cases/perl.py

@@ -1,3 +1,7 @@
+#
+# SPDX-License-Identifier: MIT
+#
+
 import os
 
 from oeqa.runtime.case import OERuntimeTestCase

+ 4 - 0
meta/lib/oeqa/runtime/cases/ping.py

@@ -1,3 +1,7 @@
+#
+# SPDX-License-Identifier: MIT
+#
+
 from subprocess import Popen, PIPE
 
 from oeqa.runtime.case import OERuntimeTestCase

+ 4 - 0
meta/lib/oeqa/runtime/cases/ptest.py

@@ -1,3 +1,7 @@
+#
+# SPDX-License-Identifier: MIT
+#
+
 import unittest
 import pprint
 import datetime

+ 4 - 0
meta/lib/oeqa/runtime/cases/python.py

@@ -1,3 +1,7 @@
+#
+# SPDX-License-Identifier: MIT
+#
+
 from oeqa.runtime.case import OERuntimeTestCase
 from oeqa.core.decorator.depends import OETestDepends
 from oeqa.runtime.decorator.package import OEHasPackage

Some files were not shown because too many files changed in this diff