Browse Source

service: tweak example recipe

* Drop PR = "r0"
* Reorder lines so that packaging definitions are at the end

Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
Paul Eggleton 8 years ago
parent
commit
e6cf787871
1 changed files with 3 additions and 4 deletions
  1. 3 4
      meta-skeleton/recipes-skeleton/service/service_0.1.bb

+ 3 - 4
meta-skeleton/recipes-skeleton/service/service_0.1.bb

@@ -2,16 +2,12 @@ SUMMARY = "The canonical example of init scripts"
 SECTION = "base"
 LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://${WORKDIR}/COPYRIGHT;md5=349c872e0066155e1818b786938876a4"
-RDEPENDS_${PN} = "initscripts"
-PR = "r0"
 
 SRC_URI = "file://skeleton \
 	   file://skeleton_test.c \
 	   file://COPYRIGHT \
 	   "
 
-CONFFILES_${PN} += "${sysconfdir}/init.d/skeleton"
-
 do_compile () {
 	${CC} ${WORKDIR}/skeleton_test.c -o ${WORKDIR}/skeleton-test
 }
@@ -30,3 +26,6 @@ do_install () {
 	install -m 0755 ${WORKDIR}/skeleton-test ${D}${sbindir}/
 }
 
+RDEPENDS_${PN} = "initscripts"
+
+CONFFILES_${PN} += "${sysconfdir}/init.d/skeleton"