Browse Source

rt-tests: Enable only for x86/ppc64 architectures

It needs frc() implementation for oslat, this is new tool added to
rt-tests recently, and there is no easy knob to configure it out at
present

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Khem Raj 3 years ago
parent
commit
e4be9e52d3

+ 7 - 1
meta/recipes-rt/images/core-image-rt-sdk.bb

@@ -15,6 +15,12 @@ DEPENDS += "linux-yocto-rt"
 
 IMAGE_FEATURES += "dev-pkgs tools-sdk tools-debug eclipse-debug tools-profile tools-testapps debug-tweaks"
 
-IMAGE_INSTALL += "rt-tests hwlatdetect kernel-dev"
+IMAGE_INSTALL += "${RTTESTS} hwlatdetect kernel-dev"
+
+RTTESTS ?= ""
+RTTESTS_powerpc64 = "rt-tests"
+RTTESTS_powerpc64le = "rt-tests"
+RTTESTS_x86 = "rt-tests"
+RTTESTS_x86-64 = "rt-tests"
 
 LICENSE = "MIT"

+ 1 - 0
meta/recipes-rt/rt-tests/rt-tests_1.9.bb

@@ -16,6 +16,7 @@ SRC_URI += " \
 
 # rt-tests needs PI mutex support in libc
 COMPATIBLE_HOST_libc-musl = 'null'
+COMPATIBLE_HOST = "(i.86.*|x86_64.*|powerpc64.*)-linux"
 
 # Do not install hwlatdetect
 EXTRA_OEMAKE += "PYLIB=''"