Переглянути джерело

nativesdk-sdk-provides-dummy: Add /bin/sh

By doing this we can revert b18c32ab6bc9c4f1953e9f79aa39bc92d1c4e30d which
was a pretty ugly hack anyway and now means the different providers are all
being handled consistently.

Anyone with SDK recipes will need to ensure nativesdk-sdk-provides-dummy
is included in those builds (or an equivalent). This is a good thing to
do anyway.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Richard Purdie 3 роки тому
батько
коміт
dd2c603bef

+ 1 - 1
meta/classes/package_rpm.bbclass

@@ -557,7 +557,7 @@ python write_specfile () {
 
     print_deps(srcrrecommends, "Recommends", spec_preamble_top, d)
     print_deps(srcrsuggests, "Suggests", spec_preamble_top, d)
-    print_deps(srcrprovides + (" /bin/sh" if srcname.startswith("nativesdk-") else ""), "Provides", spec_preamble_top, d)
+    print_deps(srcrprovides, "Provides", spec_preamble_top, d)
     print_deps(srcrobsoletes, "Obsoletes", spec_preamble_top, d)
     print_deps(srcrconflicts, "Conflicts", spec_preamble_top, d)
 

+ 1 - 0
meta/recipes-core/meta/buildtools-tarball.bb

@@ -6,6 +6,7 @@ LICENSE = "MIT"
 TOOLCHAIN_TARGET_TASK ?= ""
 
 TOOLCHAIN_HOST_TASK ?= "\
+    nativesdk-sdk-provides-dummy \
     nativesdk-python3-core \
     nativesdk-python3-modules \
     nativesdk-python3-misc \

+ 1 - 1
meta/recipes-core/meta/nativesdk-sdk-provides-dummy.bb

@@ -4,8 +4,8 @@ DUMMYPROVIDES_PACKAGES = "\
     pkgconfig \
 "
 
-# Add /bin/sh?
 DUMMYPROVIDES = "\
+    /bin/sh \
     /bin/bash \
     /usr/bin/env \
     libGL.so()(64bit) \

+ 1 - 1
meta/recipes-core/meta/testexport-tarball.bb

@@ -8,7 +8,7 @@ TEST_EXPORT_SDK_PACKAGES ??= ""
 
 TOOLCHAIN_TARGET_TASK ?= ""
 
-TOOLCHAIN_HOST_TASK ?= "${TEST_EXPORT_SDK_PACKAGES}"
+TOOLCHAIN_HOST_TASK ?= "${TEST_EXPORT_SDK_PACKAGES} nativesdk-sdk-provides-dummy"
 
 MULTIMACH_TARGET_SYS = "${SDK_ARCH}-nativesdk${SDK_VENDOR}-${SDK_OS}"
 PACKAGE_ARCH = "${SDK_ARCH}_${SDK_OS}"

+ 1 - 0
meta/recipes-core/meta/uninative-tarball.bb

@@ -18,6 +18,7 @@ TOOLCHAIN_HOST_TASK = "\
     nativesdk-libxcrypt \
     nativesdk-libxcrypt-compat \
     nativesdk-libnss-nis \
+    nativesdk-sdk-provides-dummy \
     "
 
 INHIBIT_DEFAULT_DEPS = "1"