Преглед изворни кода

libxml-simple-perl: upgrade 2.24 -> 2.25

* Fix RDEPENDS

Upstream release notes:
2.25      2018-03-18 16:18:24+13:00 Pacific/Auckland
  - disable entity expansion when using XML::Parser, for more secure default
    behaviour (patch from Ray Morris)
  - call to XML::Parser constructor is now in its own method to ease overriding

License-Update: update year to 2018

Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
Tim Orling пре 6 година
родитељ
комит
d549289fa5
1 измењених фајлова са 14 додато и 3 уклоњено
  1. 14 3
      meta/recipes-devtools/perl/libxml-simple-perl_2.25.bb

+ 14 - 3
meta/recipes-devtools/perl/libxml-simple-perl_2.24.bb → meta/recipes-devtools/perl/libxml-simple-perl_2.25.bb

@@ -7,13 +7,13 @@ where the original uses plain Perl or SAX parsers."
 HOMEPAGE = "http://search.cpan.org/~markov/XML-LibXML-Simple-0.93/lib/XML/LibXML/Simple.pod"
 SECTION = "libs"
 LICENSE = "Artistic-1.0 | GPL-1.0+"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=23477e18a0d04392cdf44ae70e49b495"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=cf206df8c9fe775f1d4c484386491eac"
 DEPENDS += "libxml-parser-perl"
 
 SRC_URI = "http://www.cpan.org/modules/by-module/XML/XML-Simple-${PV}.tar.gz"
 
-SRC_URI[md5sum] = "1cd2e8e3421160c42277523d5b2f4dd2"
-SRC_URI[sha256sum] = "9a14819fd17c75fbb90adcec0446ceab356cab0ccaff870f2e1659205dc2424f"
+SRC_URI[md5sum] = "bb841dce889a26c89a1c2739970e9fbc"
+SRC_URI[sha256sum] = "531fddaebea2416743eb5c4fdfab028f502123d9a220405a4100e68fc480dbf8"
 
 S = "${WORKDIR}/XML-Simple-${PV}"
 
@@ -21,4 +21,15 @@ EXTRA_PERLFLAGS = "-I ${PERLHOSTLIB}"
 
 inherit cpan ptest-perl
 
+RDEPENDS_${PN} += " \
+    libxml-namespacesupport-perl \
+    libxml-parser-perl \
+    libxml-sax-perl \
+"
+
+RDEPENDS_${PN}-ptest += " \
+    perl-module-file-temp \
+    perl-module-test-more \
+"
+
 BBCLASSEXTEND = "native"