Explorar o código

u-boot: install dumpimage and fit_check_sign in u-boot-tools

Dumpimage and fit_check_sign can be used to extract kernel and ramdisk from
a FIT file, verify them and kexec for a faster reboot.

Signed-off-by: Luca Boccassi <luca.boccassi@microsoft.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Luca Boccassi %!s(int64=5) %!d(string=hai) anos
pai
achega
c99255d688
Modificáronse 1 ficheiros con 9 adicións e 1 borrados
  1. 9 1
      meta/recipes-bsp/u-boot/u-boot-tools_2019.01.bb

+ 9 - 1
meta/recipes-bsp/u-boot/u-boot-tools_2019.01.bb

@@ -45,11 +45,19 @@ do_install () {
 	# mkenvimage
 	install -m 0755 tools/mkenvimage ${D}${bindir}/uboot-mkenvimage
 	ln -sf uboot-mkenvimage ${D}${bindir}/mkenvimage
+
+	# dumpimage
+	install -m 0755 tools/dumpimage ${D}${bindir}/uboot-dumpimage
+	ln -sf uboot-dumpimage ${D}${bindir}/dumpimage
+
+	# fit_check_sign
+	install -m 0755 tools/fit_check_sign ${D}${bindir}/uboot-fit_check_sign
+	ln -sf uboot-fit_check_sign ${D}${bindir}/fit_check_sign
 }
 
 ALLOW_EMPTY_${PN} = "1"
 FILES_${PN} = ""
-FILES_${PN}-mkimage = "${bindir}/uboot-mkimage ${bindir}/mkimage"
+FILES_${PN}-mkimage = "${bindir}/uboot-mkimage ${bindir}/mkimage ${bindir}/uboot-dumpimage ${bindir}/dumpimage ${bindir}/uboot-fit_check_sign ${bindir}/fit_check_sign"
 FILES_${PN}-mkenvimage = "${bindir}/uboot-mkenvimage ${bindir}/mkenvimage"
 
 RDEPENDS_${PN}-mkimage += "dtc"