Переглянути джерело

gnutils: Security fix CVE-2016-7444

affects gnutls < 3.3.24

Signed-off-by: Armin Kuster <akuster808@gmail.com>
Armin Kuster 7 роки тому
батько
коміт
c0a682cfee

+ 31 - 0
meta/recipes-support/gnutls/gnutls/CVE-2016-7444.patch

@@ -0,0 +1,31 @@
+From 964632f37dfdfb914ebc5e49db4fa29af35b1de9 Mon Sep 17 00:00:00 2001
+From: Nikos Mavrogiannopoulos <nmav@gnutls.org>
+Date: Sat, 27 Aug 2016 17:00:22 +0200
+Subject: [PATCH] ocsp: corrected the comparison of the serial size in OCSP
+ response
+
+Previously the OCSP certificate check wouldn't verify the serial length
+and could succeed in cases it shouldn't.
+
+Reported by Stefan Buehler.
+
+Upstream-Status: Backport
+CVE: CVE-2016-7444
+Signed-off-by: Armin Kuster <akuster@mvista.com>
+
+---
+ lib/x509/ocsp.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+Index: gnutls-3.3.17.1/lib/x509/ocsp.c
+===================================================================
+--- gnutls-3.3.17.1.orig/lib/x509/ocsp.c
++++ gnutls-3.3.17.1/lib/x509/ocsp.c
+@@ -1257,6 +1257,7 @@ gnutls_ocsp_resp_check_crt(gnutls_ocsp_r
+ 		gnutls_assert();
+ 		goto cleanup;
+ 	}
++	cserial.size = t;
+ 
+ 	if (rserial.size != cserial.size
+ 	    || memcmp(cserial.data, rserial.data, rserial.size) != 0) {

+ 1 - 0
meta/recipes-support/gnutls/gnutls_3.3.17.1.bb

@@ -3,6 +3,7 @@ require gnutls.inc
 SRC_URI += "file://correct_rpl_gettimeofday_signature.patch \
             file://configure.ac-fix-sed-command.patch \
             file://use-pkg-config-to-locate-zlib.patch \
+            file://CVE-2016-7444.patch \
            "
 SRC_URI[md5sum] = "8d01c7e7f2cbc5871fdca832d2260b6b"
 SRC_URI[sha256sum] = "b40f158030a92f450a07b20300a3996710ca19800848d9f6fd62493170c5bbb4"