Browse Source

systemd: Package systemd-hwdb-update.service into udev

Currently, this unit is packaged into udev-hwdb which then adds it as rdep
instead of rrecommends to systemd itself, this meant that even if we
added udev-hwdb to BAD_RECOMMENDATIONS, it would not be respected since
its a rdep, therefore move the service unit file into udev package
instead, this decouples the hard runtime dependency and restores the bad
recommendations expectations

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Cc: Alex Kiernan <alex.kiernan@gmail.com>
Cc: Otavio Salvador <otavio@ossystems.com.br>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Khem Raj 4 years ago
parent
commit
bfaaefe834
1 changed files with 2 additions and 1 deletions
  1. 2 1
      meta/recipes-core/systemd/systemd_244.3.bb

+ 2 - 1
meta/recipes-core/systemd/systemd_244.3.bb

@@ -628,14 +628,15 @@ FILES_udev += "${base_sbindir}/udevd \
                ${sysconfdir}/init.d/systemd-udevd \
                ${systemd_unitdir}/system/*udev* \
                ${systemd_unitdir}/system/*.wants/*udev* \
+               ${base_bindir}/systemd-hwdb \
                ${base_bindir}/udevadm \
                ${base_sbindir}/udevadm \
                ${libexecdir}/${MLPREFIX}udevadm \
                ${datadir}/bash-completion/completions/udevadm \
+               ${systemd_unitdir}/system/systemd-hwdb-update.service \
               "
 
 FILES_udev-hwdb = "${rootlibexecdir}/udev/hwdb.d \
-                   ${systemd_unitdir}/system/systemd-hwdb-update.service \
                    "
 
 RCONFLICTS_${PN} = "tiny-init ${@bb.utils.contains('PACKAGECONFIG', 'resolved', 'resolvconf', '', d)}"