Преглед изворни кода

hello-mod: Ensure the produced package name begins with kernel-module-

The special key kernel-module- is necessary for the system to avoid a package
rename when installing a multilib image.  For example:

local.conf: IMAGE_INSTALL_append = " hello-mod"

bitbake lib32-core-image-minimal

The system will translate names and prepend 'lib32-', unless the package
begins with kernel-module-.

Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Mark Hatle пре 11 година
родитељ
комит
b847f87f42
1 измењених фајлова са 8 додато и 0 уклоњено
  1. 8 0
      meta-skeleton/recipes-kernel/hello-mod/hello-mod_0.1.bb

+ 8 - 0
meta-skeleton/recipes-kernel/hello-mod/hello-mod_0.1.bb

@@ -13,3 +13,11 @@ SRC_URI = "file://Makefile \
           "
 
 S = "${WORKDIR}"
+
+# Kernel module packages MUST begin with 'kernel-module-', otherwise
+# multilib image generation can fail.
+#
+# The following line is only necessary if the recipe name does not begin
+# with kernel-module-.
+#
+PKG_${PN} = "kernel-module-${PN}"