Forráskód Böngészése

db: do not install db_verify if 'verify' is not enabled

On target, when running `db_verify /var/lib/rpm/Packages', we get
the following error.

  db_verify: BDB0571 library build did not include support for database verification

This is because db_verify is installed but 'verify' PACKAGECONFIG is
not enabled. So fix it by not installing do_verify in such case.

Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Chen Qi 4 éve
szülő
commit
b5ffdb296f
1 módosított fájl, 3 hozzáadás és 0 törlés
  1. 3 0
      meta/recipes-support/db/db_5.3.28.bb

+ 3 - 0
meta/recipes-support/db/db_5.3.28.bb

@@ -109,6 +109,9 @@ do_install_append() {
 	fi
 
 	chown -R root:root ${D}
+	if ${@bb.utils.contains('PACKAGECONFIG', 'verify', 'false', 'true', d)}; then
+		rm -f ${D}${bindir}/db_verify
+	fi
 }
 
 INSANE_SKIP_${PN} = "dev-so"