Browse Source

python: remove the PN package entirely

Nothing should be in this package, so remove it entirely to be sure nothing does
end up in there.

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Ross Burton 5 years ago
parent
commit
b4ea23adf5

+ 2 - 2
meta/recipes-devtools/python/python3_3.5.6.bb

@@ -215,6 +215,8 @@ py_package_preprocess () {
 	mv ${PKGD}/${bindir}/python${PYTHON_BINABI}-config ${PKGD}/${bindir}/python${PYTHON_BINABI}-config-${MULTILIB_SUFFIX}
 }
 
+PACKAGES_remove = "${PN}"
+
 # manual dependency additions
 RPROVIDES_${PN}-modules = "${PN}"
 RRECOMMENDS_${PN}-core_append_class-nativesdk = " nativesdk-python3-modules"
@@ -249,8 +251,6 @@ RDEPENDS_${PN}-dev = ""
 
 BBCLASSEXTEND = "nativesdk"
 
-RPROVIDES_${PN} += "${PN}-modules"
-
 # We want bytecode precompiled .py files (.pyc's) by default
 # but the user may set it on their own conf
 INCLUDE_PYCS ?= "1"

+ 1 - 2
meta/recipes-devtools/python/python_2.7.15.bb

@@ -152,6 +152,7 @@ py_package_preprocess () {
 	(cd ${PKGD}; python -m py_compile ./${libdir}/python${PYTHON_MAJMIN}/_sysconfigdata.py)
 }
 
+PACKAGES_remove = "${PN}"
 
 # manual dependency additions
 RPROVIDES_${PN}-core = "${PN}"
@@ -181,8 +182,6 @@ RDEPENDS_${PN}-dev = ""
 
 BBCLASSEXTEND = "nativesdk"
 
-RPROVIDES_${PN} += "${PN}-modules"
-
 # We want bytecode precompiled .py files (.pyc's) by default
 # but the user may set it on their own conf