Browse Source

grep: Fix shell after autotools changes

After changing autotools.bbclass, CONFIG_SHELL setting no longer works
resulting in:

grep-3.4-r0 do_package_qa: QA Issue: /bin/fgrep.grep contained in package grep requires /bin/bash, but no providers found in RDEPENDS_grep? [file-rdeps]

The script can use /bin/sh so set this specifically using sed since we
want to use a consistent shell for the rest of the build but not have
the specific bash dependency.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Richard Purdie 4 years ago
parent
commit
9031b66c7c
1 changed files with 1 additions and 2 deletions
  1. 1 2
      meta/recipes-extended/grep/grep_3.4.bb

+ 1 - 2
meta/recipes-extended/grep/grep_3.4.bb

@@ -16,6 +16,7 @@ inherit autotools gettext texinfo pkgconfig
 acpaths = "-I ./m4"
 
 do_configure_prepend () {
+	sed -i -e '1s,#!@SHELL@,#!/bin/sh,' ${S}/src/egrep.sh
 	rm -f ${S}/m4/init.m4
 }
 
@@ -41,5 +42,3 @@ ALTERNATIVE_${PN} = "grep egrep fgrep"
 ALTERNATIVE_LINK_NAME[grep] = "${base_bindir}/grep"
 ALTERNATIVE_LINK_NAME[egrep] = "${base_bindir}/egrep"
 ALTERNATIVE_LINK_NAME[fgrep] = "${base_bindir}/fgrep"
-
-export CONFIG_SHELL="/bin/sh"