Просмотр исходного кода

Rename the remaining poky-* scripts to oe-* or runqemu-*

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Richard Purdie 13 лет назад
Родитель
Сommit
877b3d8459

+ 1 - 1
.gitignore

@@ -7,7 +7,7 @@ build/tmp/
 build/sstate-cache
 build/pyshtables.py
 pstage/
-scripts/poky-git-proxy-socks
+scripts/oe-git-proxy-socks
 sources/
 meta-darwin
 meta-maemo

+ 1 - 1
meta/classes/image.bbclass

@@ -216,7 +216,7 @@ rootfs_trim_schemas () {
 	do
 		# Need this in case no files exist
 		if [ -e $schema ]; then
-			poky-trim-schemas $schema > $schema.new
+			oe-trim-schemas $schema > $schema.new
         	        mv $schema.new $schema
 		fi
 	done

+ 3 - 3
meta/conf/site.conf.sample

@@ -20,7 +20,7 @@ SCONF_VERSION = "1"
 # although this only works for http
 #GIT_PROXY_HOST = "proxy.example.com"
 #GIT_PROXY_PORT = "81"
-#export GIT_PROXY_COMMAND = "${COREBASE}/scripts/poky-git-proxy-command"
+#export GIT_PROXY_COMMAND = "${COREBASE}/scripts/oe-git-proxy-command"
 
 # GIT_PROXY_IGNORE_* lines define hosts which do not require a proxy to access
 #GIT_CORE_CONFIG = "Yes"
@@ -28,11 +28,11 @@ SCONF_VERSION = "1"
 #GIT_PROXY_IGNORE_2 = "another.server.com"
 
 # If SOCKS is available run the following command to comple a simple transport
-# gcc scripts/poky-git-proxy-socks.c -o poky-git-proxy-socks
+# gcc scripts/oe-git-proxy-socks.c -o oe-git-proxy-socks
 # and then share that binary somewhere in PATH, then use the following settings
 #GIT_PROXY_HOST = "proxy.example.com"
 #GIT_PROXY_PORT = "81"
-#export GIT_PROXY_COMMAND = "${COREBASE}/scripts/poky-git-proxy-socks-command"
+#export GIT_PROXY_COMMAND = "${COREBASE}/scripts/oe-git-proxy-socks-command"
 
 
 # Uncomment this to use a shared download directory

+ 7 - 6
meta/recipes-devtools/qemu/qemu-helper-nativesdk_1.0.bb

@@ -11,13 +11,13 @@ LIC_FILES_CHKSUM = "file://${WORKDIR}/tunctl.c;endline=4;md5=ff3a09996bc5fff6bc5
 
 SRC_URI = "file://${COREBASE}/scripts/runqemu \
            file://${COREBASE}/scripts/runqemu-internal \
-           file://${COREBASE}/scripts/poky-addptable2image \
-           file://${COREBASE}/scripts/poky-gen-tapdevs \
+           file://${COREBASE}/scripts/runqemu-addptable2image \
+           file://${COREBASE}/scripts/runqemu-gen-tapdevs \
            file://${COREBASE}/scripts/runqemu-ifup \
            file://${COREBASE}/scripts/runqemu-ifdown \
-           file://${COREBASE}/scripts/poky-find-native-sysroot \
-           file://${COREBASE}/scripts/poky-extract-sdk \
-           file://${COREBASE}/scripts/poky-export-rootfs \
+           file://${COREBASE}/scripts/oe-find-native-sysroot \
+           file://${COREBASE}/scripts/runqemu-extract-sdk \
+           file://${COREBASE}/scripts/runqemu-export-rootfs \
            file://tunctl.c \
            file://raw2flash.c \
           "
@@ -34,7 +34,8 @@ do_compile() {
 
 do_install() {
 	install -d ${D}${bindir}
-	install -m 0755 ${WORKDIR}${COREBASE}/scripts/poky-* ${D}${bindir}/
+	install -m 0755 ${WORKDIR}${COREBASE}/scripts/oe-* ${D}${bindir}/
+	install -m 0755 ${WORKDIR}${COREBASE}/scripts/runqemu* ${D}${bindir}/
 	install tunctl ${D}${bindir}/
 	install raw2flash.spitz ${D}${bindir}/
 	install flash2raw.spitz ${D}${bindir}/

+ 1 - 1
scripts/poky-find-native-sysroot → scripts/oe-find-native-sysroot

@@ -8,7 +8,7 @@
 # This script is intended to be run within other scripts by source'ing
 # it, e.g:
 #
-# SYSROOT_SETUP_SCRIPT=`which poky-find-native-sysroot`
+# SYSROOT_SETUP_SCRIPT=`which oe-find-native-sysroot`
 # . $SYSROOT_SETUP_SCRIPT
 #
 # This script will terminate execution of your calling program unless

+ 0 - 0
scripts/poky-git-proxy-command → scripts/oe-git-proxy-command


+ 2 - 0
scripts/oe-git-proxy-socks-command

@@ -0,0 +1,2 @@
+#! /bin/bash
+oe-git-proxy-socks -S $GIT_PROXY_HOST:$GIT_PROXY_PORT $@

+ 0 - 0
scripts/poky-git-proxy-socks.c → scripts/oe-git-proxy-socks.c


+ 0 - 0
scripts/poky-setup-rpmrepo → scripts/oe-setup-rpmrepo


+ 0 - 0
scripts/poky-trim-schemas → scripts/oe-trim-schemas


+ 0 - 2
scripts/poky-git-proxy-socks-command

@@ -1,2 +0,0 @@
-#! /bin/bash
-poky-git-proxy-socks -S $GIT_PROXY_HOST:$GIT_PROXY_PORT $@

+ 0 - 0
scripts/poky-addptable2image → scripts/runqemu-addptable2image


+ 3 - 3
scripts/poky-export-rootfs → scripts/runqemu-export-rootfs

@@ -38,9 +38,9 @@ fi
 # Ensure the nfs-export-dir is an absolute path
 NFS_EXPORT_DIR=$(cd "$2" && pwd)
 
-SYSROOT_SETUP_SCRIPT=`which poky-find-native-sysroot`
+SYSROOT_SETUP_SCRIPT=`which oe-find-native-sysroot`
 if [ -z "$SYSROOT_SETUP_SCRIPT" ]; then
-    echo "Error: Unable to find the poky-find-native-sysroot script"
+    echo "Error: Unable to find the oe-find-native-sysroot script"
     echo "Did you forget to source your Poky environment script?"
     exit 1
 fi
@@ -73,7 +73,7 @@ export PSEUDO_LOCALSTATEDIR
 
 if [ ! -d "$PSEUDO_LOCALSTATEDIR" ]; then
 	echo "Error: $PSEUDO_LOCALSTATEDIR does not exist."
-	echo "Did you create the export directory using poky-extract-sdk?"
+	echo "Did you create the export directory using runqemu-extract-sdk?"
 	exit 1	
 fi
 

+ 2 - 2
scripts/poky-extract-sdk → scripts/runqemu-extract-sdk

@@ -29,9 +29,9 @@ if [ $# -ne 2 ]; then
 	exit 1
 fi
 
-SYSROOT_SETUP_SCRIPT=`which poky-find-native-sysroot`
+SYSROOT_SETUP_SCRIPT=`which oe-find-native-sysroot`
 if [ -z "$SYSROOT_SETUP_SCRIPT" ]; then
-    echo "Error: Unable to find the poky-find-native-sysroot script"
+    echo "Error: Unable to find the oe-find-native-sysroot script"
     echo "Did you forget to source your Poky environment script?"
     exit 1
 fi

+ 0 - 0
scripts/poky-gen-tapdevs → scripts/runqemu-gen-tapdevs


+ 1 - 1
scripts/runqemu-ifup

@@ -14,7 +14,7 @@
 # <my-username> ALL=NOPASSWD: /path/to/runqemu-ifdown
 #
 # If you'd like to create a bank of tap devices at once, you should use
-# the poky-gen-tapdevs script instead. If tap devices are set up using
+# the runqemu-gen-tapdevs script instead. If tap devices are set up using
 # that script, the runqemu script will never end up calling this
 # script.
 #

+ 6 - 6
scripts/runqemu-internal

@@ -83,7 +83,7 @@ fi
 if [ -z "$mem_set" ] ; then
   SCRIPT_QEMU_EXTRA_OPT="$SCRIPT_QEMU_EXTRA_OPT -m $mem_size"
 fi
-# This file is created when poky-gen-tapdevs creates a bank of tap
+# This file is created when runqemu-gen-tapdevs creates a bank of tap
 # devices, indicating that the user should not bring up new ones using
 # sudo.
 NOSUDO_FLAG="/etc/poky-nosudo"
@@ -186,8 +186,8 @@ cleanup() {
 
     if [ "$NFSRUNNING" = "true" ]; then
         echo "Shutting down the userspace NFS server..."
-        echo "poky-export-rootfs stop $ROOTFS"
-        poky-export-rootfs stop $ROOTFS
+        echo "runqemu-export-rootfs stop $ROOTFS"
+        runqemu-export-rootfs stop $ROOTFS
     fi
     # If QEMU crashes or somehow tty properties are not restored
     # after qemu exits, we need to run stty sane
@@ -258,8 +258,8 @@ if [ "$FSTYPE" = "nfs" ]; then
     fi
 
     # Start the userspace NFS server
-    echo "poky-export-rootfs restart $ROOTFS"
-    poky-export-rootfs restart $ROOTFS
+    echo "runqemu-export-rootfs restart $ROOTFS"
+    runqemu-export-rootfs restart $ROOTFS
     if [ $? != 0 ]; then
         cleanup
         return
@@ -351,7 +351,7 @@ if [ "$MACHINE" = "spitz" ]; then
         echo $ROOTFS
         if [ ! -e "$ROOTFS.qemudisk" ]; then
             echo "Adding a partition table to the ext3 image for use by QEMU, please wait..."
-            poky-addptable2image $ROOTFS $ROOTFS.qemudisk
+            runqemu-addptable2image $ROOTFS $ROOTFS.qemudisk
         fi
         QEMUOPTIONS="$QEMU_NETWORK_CMD -M spitz -hda $ROOTFS.qemudisk -portrait"
     fi