Browse Source

python3-subunit: ensure runtime dependencies are present

Without access to unittest, subunit cannot be imported in python3:

    root@qemux86-64:~# python3
    Python 3.7.4 (default, Sep 20 2019, 13:38:31)
    [GCC 9.2.0] on linux
    Type "help", "copyright", "credits" or "license" for more information.
    >>> import subunit
    Traceback (most recent call last):
      File "<stdin>", line 1, in <module>
      File "/usr/lib/python3.7/site-packages/subunit/__init__.py", line 123, in <module>
        import unittest
    ModuleNotFoundError: No module named 'unittest'
    >>>

Adding python3-testtools to python3-subunit's RDEPENDS fixes the
issue. This also implicitly provides the functionality found in
the python3-extras module.

Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Trevor Gamblin 4 years ago
parent
commit
7ed7dc39e3
1 changed files with 2 additions and 0 deletions
  1. 2 0
      meta/recipes-devtools/python/python3-subunit_1.3.0.bb

+ 2 - 0
meta/recipes-devtools/python/python3-subunit_1.3.0.bb

@@ -1,2 +1,4 @@
 inherit setuptools3
 require python-subunit.inc
+
+RDEPENDS_${PN} = " python3-testtools"