Преглед изворни кода

gstreamer1.0: fix builds with make 4.3

Depend on make-native instead of using host make to avoid errors like:

| controller-enumtypes.c:10:1: error: stray '\' in program
|    10 | \#include "gstinterpolationcontrolsource.h"
|       | ^
| controller-enumtypes.c:10:2: error: stray '#' in program
|    10 | \#include "gstinterpolationcontrolsource.h"
|       |  ^
| controller-enumtypes.c:10:11: error: expected '=', ',', ';', 'asm' or '__attribute__' before string constant
|    10 | \#include "gstinterpolationcontrolsource.h"
|       |           ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
| controller-enumtypes.c:11:1: error: stray '\' in program
|    11 | \#include "gstlfocontrolsource.h"
|       | ^
| controller-enumtypes.c:11:2: error: stray '#' in program
|    11 | \#include "gstlfocontrolsource.h"

This helps building on autobuilder where some workers have buildtools
with make 4.3 installed.

Building using meson works fine so later branches are not affected and
upstream has rejected patches to fix this:

https://gitlab.freedesktop.org/gstreamer/gstreamer/-/issues/515

Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Anuj Mittal пре 3 година
родитељ
комит
74e22d0d2b

+ 1 - 1
meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins.inc

@@ -3,7 +3,7 @@ HOMEPAGE = "http://gstreamer.freedesktop.org/"
 BUGTRACKER = "https://bugzilla.gnome.org/enter_bug.cgi?product=Gstreamer"
 SECTION = "multimedia"
 
-DEPENDS = "gstreamer1.0 glib-2.0-native"
+DEPENDS = "gstreamer1.0 glib-2.0-native make-native"
 
 SRC_URI_append = " file://gtk-doc-tweaks.patch"
 

+ 1 - 1
meta/recipes-multimedia/gstreamer/gstreamer1.0-rtsp-server_1.16.2.bb

@@ -4,7 +4,7 @@ SECTION = "multimedia"
 LICENSE = "LGPLv2"
 LIC_FILES_CHKSUM = "file://COPYING;md5=6762ed442b3822387a51c92d928ead0d"
 
-DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base"
+DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base make-native"
 
 PNREAL = "gst-rtsp-server"
 

+ 1 - 1
meta/recipes-multimedia/gstreamer/gstreamer1.0_1.16.2.bb

@@ -6,7 +6,7 @@ BUGTRACKER = "https://bugzilla.gnome.org/enter_bug.cgi?product=Gstreamer"
 SECTION = "multimedia"
 LICENSE = "LGPLv2+"
 
-DEPENDS = "glib-2.0 glib-2.0-native libcap libxml2 bison-native flex-native"
+DEPENDS = "glib-2.0 glib-2.0-native libcap libxml2 bison-native flex-native make-native"
 
 inherit autotools pkgconfig gettext upstream-version-is-even gobject-introspection gtk-doc ptest