Browse Source

ethtool, libcap: fix upstream version check

The default URI returns a gzip-compressed index page
which browsers can auto-detect, but we can't.

Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Alexander Kanavin 4 years ago
parent
commit
73eb644db1

+ 2 - 0
meta/recipes-extended/ethtool/ethtool_5.2.bb

@@ -14,6 +14,8 @@ SRC_URI = "${KERNELORG_MIRROR}/software/network/ethtool/ethtool-${PV}.tar.gz \
 SRC_URI[md5sum] = "79cff0d4af62b030ad28be90414b5c4a"
 SRC_URI[sha256sum] = "8ad6cb30f6e1767d9d23a5cb5f606f3b51f83e85ebf0153c1506194f6709e90b"
 
+UPSTREAM_CHECK_URI = "https://www.kernel.org/pub/software/network/ethtool/"
+
 inherit autotools ptest bash-completion
 
 RDEPENDS_${PN}-ptest += "make"

+ 2 - 0
meta/recipes-support/libcap/libcap_2.27.bb

@@ -13,6 +13,8 @@ SRC_URI = "${KERNELORG_MIRROR}/linux/libs/security/linux-privs/${BPN}2/${BPN}-${
 SRC_URI[md5sum] = "2e8f9fab32eb5ccb37969fe317fd17aa"
 SRC_URI[sha256sum] = "dac1792d0118bee6aae6ba7fb93ff1602c6a9bda812fd63916eee1435b9c486a"
 
+UPSTREAM_CHECK_URI = "https://www.kernel.org/pub/linux/libs/security/linux-privs/${BPN}2/"
+
 inherit lib_package
 
 # do NOT pass target cflags to host compilations