Browse Source

gdk-pixbuf: remove a test that sporadically fails without reproducibility

The test is randomly modifying file data and some of these random
modifications cause OOM failures. There is no way to preserve and repeat
what was modified, so the test needs to re-engineered to do
proper fuzzing.

See here for details:
https://gitlab.gnome.org/GNOME/gdk-pixbuf/-/issues/146

Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Alexander Kanavin 4 years ago
parent
commit
732a9c83e9
1 changed files with 5 additions and 0 deletions
  1. 5 0
      meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.40.0.bb

+ 5 - 0
meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.40.0.bb

@@ -99,6 +99,11 @@ do_install_append() {
 
 }
 
+# Remove a bad fuzzing attempt that sporadically fails without a way to reproduce
+do_install_ptest() {
+	rm ${D}/${datadir}/installed-tests/gdk-pixbuf/pixbuf-randomly-modified.test
+}
+
 do_install_append_class-native() {
 	find ${D}${libdir} -name "libpixbufloader-*.la" -exec rm \{\} \;