Browse Source

matchbox-panel-2: Fix small systray icon drawing

Add patch to pack systray icons so that their drawing area is the
size they expect (otherwise GtkStatusIcon based systray items can
end up drawing "tiled", looking like 1.5 icons instead of a single
icon).

Fixes [YOCTO #9995]

Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Jussi Kukkonen 7 years ago
parent
commit
6db56c4fd1

+ 34 - 0
meta/recipes-sato/matchbox-panel-2/files/0001-applets-systray-Allow-icons-to-be-smaller.patch

@@ -0,0 +1,34 @@
+From f83a9179696b2d060ee4860733dafbf38bbd4b87 Mon Sep 17 00:00:00 2001
+From: Jussi Kukkonen <jussi.kukkonen@intel.com>
+Date: Wed, 28 Sep 2016 15:05:41 +0300
+Subject: [PATCH] applets/systray: Allow icons to be smaller
+
+Don't expand/fill the systray items, align them in the center of the
+systray panel. This makes sure the icons are drawn at the size they
+expect.
+
+Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
+Upstream-Status: Submitted
+---
+ applets/systray/systray.c | 5 +++--
+ 1 file changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/applets/systray/systray.c b/applets/systray/systray.c
+index 39698a8..94a5753 100644
+--- a/applets/systray/systray.c
++++ b/applets/systray/systray.c
+@@ -29,8 +29,9 @@ on_realize (GtkWidget *widget, gpointer user_data)
+   tray = (GtkWidget *)na_tray_new_for_screen (screen, orientation);
+ 
+   gtk_widget_show (tray);
+-
+-  gtk_container_add (GTK_CONTAINER (widget), tray);
++  gtk_widget_set_valign (tray, GTK_ALIGN_CENTER);
++  gtk_widget_set_halign (tray, GTK_ALIGN_CENTER);
++  gtk_box_pack_start (GTK_BOX (widget), tray, FALSE, FALSE, 0);
+ }
+ 
+ G_MODULE_EXPORT GtkWidget *
+-- 
+2.1.4
+

+ 3 - 1
meta/recipes-sato/matchbox-panel-2/matchbox-panel-2_2.11.bb

@@ -21,7 +21,9 @@ RPROVIDES_${PN} = "matchbox-panel"
 RREPLACES_${PN} = "matchbox-panel"
 RCONFLICTS_${PN} = "matchbox-panel"
 
-SRC_URI = "git://git.yoctoproject.org/${BPN}"
+SRC_URI = "git://git.yoctoproject.org/${BPN} \
+           file://0001-applets-systray-Allow-icons-to-be-smaller.patch \
+           "
 
 EXTRA_OECONF = "--enable-startup-notification --enable-dbus"
 EXTRA_OECONF += " ${@bb.utils.contains("MACHINE_FEATURES", "acpi", "--with-battery=acpi", "",d)}"