Browse Source

gconf: add patch to remove '+' from invalid characters list

This will allow gconftool-2 to run when configuration source addresses
contain the '+' sign.

[YOCTO #3893]

Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Laurentiu Palcu 11 years ago
parent
commit
5ba4d94718

+ 19 - 0
meta/recipes-gnome/gnome/gconf-3.2.5/remove_plus_from_invalid_characters_list.patch

@@ -0,0 +1,19 @@
+Upstream-Status: Pending
+
+Remove '+' from invalid characters list
+
+Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com>
+
+Index: GConf-3.2.5/gconf/gconf-backend.c
+===================================================================
+--- GConf-3.2.5.orig/gconf/gconf-backend.c
++++ GConf-3.2.5/gconf/gconf-backend.c
+@@ -37,7 +37,7 @@ static const char invalid_chars[] =
+   /* Space is common in user names (and thus home directories) on Windows */
+   " "
+ #endif
+-  "\t\r\n\"$&<>,+=#!()'|{}[]?~`;%\\";
++  "\t\r\n\"$&<>,=#!()'|{}[]?~`;%\\";
+ 
+ static gboolean
+ gconf_address_valid (const char  *address,

+ 1 - 0
meta/recipes-gnome/gnome/gconf_3.2.5.bb

@@ -15,6 +15,7 @@ inherit gnomebase gtk-doc
 
 SRC_URI = "${GNOME_MIRROR}/GConf/${@gnome_verdir("${PV}")}/GConf-${PV}.tar.xz;name=archive \
            file://obsolete_automake_macros.patch \
+           file://remove_plus_from_invalid_characters_list.patch \
 "
 
 S = "${WORKDIR}/GConf-${PV}"