Quellcode durchsuchen

recipes-test: exclude recipes from world target

These recipes should be excluded from target 'world' because these are
just intended to be used internally by oe-selftest (devtool, recipetool, etc.)

Signed-off-by: Leonardo Sandoval <leonardo.sandoval.gonzalez@linux.intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
Leonardo Sandoval vor 7 Jahren
Ursprung
Commit
4868bc94b8

+ 2 - 0
meta-selftest/recipes-test/aspell/aspell_0.0.0.1.bb

@@ -14,6 +14,8 @@ SRC_URI = "${GNU_MIRROR}/aspell/aspell-${PV}.tar.gz"
 SRC_URI[md5sum] = "e66a9c9af6a60dc46134fdacf6ce97d7"
 SRC_URI[sha256sum] = "f52583a83a63633701c5f71db3dc40aab87b7f76b29723aeb27941eff42df6e1"
 
+EXCLUDE_FROM_WORLD = "1"
+
 PACKAGECONFIG ??= ""
 PACKAGECONFIG[curses] = "--enable-curses,--disable-curses,ncurses"
 

+ 1 - 0
meta-selftest/recipes-test/devtool/devtool-test-localonly.bb

@@ -4,3 +4,4 @@ INHIBIT_DEFAULT_DEPS = "1"
 SRC_URI = "file://file1 \
            file://file2"
 
+EXCLUDE_FROM_WORLD = "1"

+ 1 - 0
meta-selftest/recipes-test/devtool/devtool-test-patch-gz.bb

@@ -14,3 +14,4 @@ SRC_URI[sha256sum] = "67c2fc94a7ecedbaae0d1837e82e93d1d98f4a6d759828860e552119af
 
 inherit autotools pkgconfig
 
+EXCLUDE_FROM_WORLD = "1"

+ 2 - 0
meta-selftest/recipes-test/devtool/devtool-test-subdir.bb

@@ -5,3 +5,5 @@ SRC_URI = "file://devtool-test-subdir.tar.gz \
            file://testfile;subdir=${BPN}"
 
 S = "${WORKDIR}/${BPN}"
+
+EXCLUDE_FROM_WORLD = "1"

+ 2 - 0
meta-selftest/recipes-test/devtool/devtool-upgrade-test1_1.5.3.bb

@@ -12,5 +12,7 @@ PR = "r5"
 
 S = "${WORKDIR}/pv-${PV}"
 
+EXCLUDE_FROM_WORLD = "1"
+
 inherit autotools
 

+ 2 - 0
meta-selftest/recipes-test/devtool/devtool-upgrade-test1_1.5.3.bb.upgraded

@@ -10,5 +10,7 @@ SRC_URI[sha256sum] = "9dd45391806b0ed215abee4c5ac1597d018c386fe9c1f5afd2f6bc3b07
 
 S = "${WORKDIR}/pv-${PV}"
 
+EXCLUDE_FROM_WORLD = "1"
+
 inherit autotools
 

+ 2 - 0
meta-selftest/recipes-test/devtool/devtool-upgrade-test2_git.bb

@@ -15,4 +15,6 @@ SRC_URI = "git://git.yoctoproject.org/dbus-wait"
 
 S = "${WORKDIR}/git"
 
+EXCLUDE_FROM_WORLD = "1"
+
 inherit autotools pkgconfig

+ 2 - 0
meta-selftest/recipes-test/devtool/devtool-upgrade-test2_git.bb.upgraded

@@ -14,4 +14,6 @@ SRC_URI = "git://git.yoctoproject.org/dbus-wait"
 
 S = "${WORKDIR}/git"
 
+EXCLUDE_FROM_WORLD = "1"
+
 inherit autotools pkgconfig

+ 2 - 0
meta-selftest/recipes-test/recipetool/selftest-recipetool-appendfile.bb

@@ -15,6 +15,8 @@ SRC_URI = "file://installscript.sh \
            file://selftest-replaceme-inst-todir-globfile \
            file://selftest-replaceme-inst-func"
 
+EXCLUDE_FROM_WORLD = "1"
+
 install_extrafunc() {
 	install -m 0644 ${WORKDIR}/selftest-replaceme-inst-func ${D}${datadir}/selftest-replaceme-inst-func
 }