Pārlūkot izejas kodu

libpam: Add userdb packageconfig

Add userdb packageconfig to control the building of the pam_userdb.so module.
This depends on dbm support being compiled in for the berkley db package.

Also, remove "--with-db-uniquename=_pam" from EXTRA_OECONF. It makes the checks
for libdb fail because it searches for the wrong symbols in libdb (and libdb
was not configured with --with-uniquename=_pam option).

db.do_configure:
    checking if --with-uniquename=NAME option specified... no

libpam.do_configure:
    checking for db_create_pam... no
    checking for db_create... no
    checking for dbm_store_pam... no
    checking for dbm_store... no
    checking for dbm_store in -lndbm... no

Signed-off-by: Ovidiu Panait <ovidiu.panait@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Ovidiu Panait 4 gadi atpakaļ
vecāks
revīzija
3130f43c51
1 mainītis faili ar 3 papildinājumiem un 2 dzēšanām
  1. 3 2
      meta/recipes-extended/pam/libpam_1.3.1.bb

+ 3 - 2
meta/recipes-extended/pam/libpam_1.3.1.bb

@@ -35,8 +35,7 @@ SRC_URI_append_libc-musl = " file://0001-Add-support-for-defining-missing-funcit
 
 DEPENDS = "bison-native flex flex-native cracklib libxml2-native virtual/crypt"
 
-EXTRA_OECONF = "--with-db-uniquename=_pam \
-                --includedir=${includedir}/security \
+EXTRA_OECONF = "--includedir=${includedir}/security \
                 --libdir=${base_libdir} \
                 --disable-nis \
                 --disable-regenerate-docu \
@@ -48,7 +47,9 @@ S = "${WORKDIR}/Linux-PAM-${PV}"
 
 inherit autotools gettext pkgconfig
 
+PACKAGECONFIG ??= ""
 PACKAGECONFIG[audit] = "--enable-audit,--disable-audit,audit,"
+PACKAGECONFIG[userdb] = "--enable-db=db,--enable-db=no,db,"
 
 PACKAGES += "${PN}-runtime ${PN}-xtests"
 FILES_${PN} = "${base_libdir}/lib*${SOLIBS}"