Browse Source

linux-dummy: Add do_compile_kernelmodules

Fixed:
PREFERRED_PROVIDER_virtual/kernel = "linux-dummy"

$ bitbake world
ERROR: Task do_compile in make-mod-scripts_1.0.bb depends upon non-existent task do_compile_kernelmodules in linux-dummy.bb
ERROR: Command execution failed: Exited with 1

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Robert Yang 5 years ago
parent
commit
2e8687174e
1 changed files with 5 additions and 0 deletions
  1. 5 0
      meta/recipes-kernel/linux/linux-dummy.bb

+ 5 - 0
meta/recipes-kernel/linux/linux-dummy.bb

@@ -39,6 +39,10 @@ do_compile () {
 	:
 }
 
+do_compile_kernelmodules() {
+    :
+}
+
 do_shared_workdir () {
 	:
 }
@@ -58,3 +62,4 @@ do_deploy() {
 addtask bundle_initramfs after do_install before do_deploy
 addtask deploy after do_install
 addtask shared_workdir after do_compile before do_install
+addtask compile_kernelmodules