Browse Source

intltool: Adds gettext as a DEPENDS

When setting USE_NLS="no" and building systemd-boot
(which DEPENDS on intltool), configure fails,
complaining about missing gettext:

configure: error: GNU gettext tools not found; required for intltool

This is caused because USE_NLS="no" makes the gettext class
add gettext-minimal-native to BASEDEPENDS instead of adding
gettext-native.

Since we still would like to set USE_NLS="no" and build systemd-boot,
we add gettext-native as a dependency to intltool-native, which makes it
available for the configure script of systemd-boot fixing the problem.

[YOCTO #11562]

Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
Alejandro Hernandez 7 years ago
parent
commit
26bd53aebf
1 changed files with 1 additions and 1 deletions
  1. 1 1
      meta/recipes-devtools/intltool/intltool_0.51.0.bb

+ 1 - 1
meta/recipes-devtools/intltool/intltool_0.51.0.bb

@@ -16,7 +16,7 @@ UPSTREAM_CHECK_URI = "https://launchpad.net/intltool/trunk/"
 
 DEPENDS = "libxml-parser-perl-native"
 RDEPENDS_${PN} = "gettext-dev libxml-parser-perl"
-DEPENDS_class-native = "libxml-parser-perl-native"
+DEPENDS_class-native = "libxml-parser-perl-native gettext-native"
 
 inherit autotools pkgconfig perlnative