Browse Source

scripts/create-recipe: Bugfixes for create-recipe easy_install handling.

1. Tell easy_install to always download, regardless of python
   install content.
2. Support https/ftp et.c. URLs provided by easy_install

Signed-off-by: David Nyström <david.nystrom@enea.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
David Nyström 11 years ago
parent
commit
18e3654894
1 changed files with 3 additions and 3 deletions
  1. 3 3
      scripts/create-recipe

+ 3 - 3
scripts/create-recipe

@@ -1918,9 +1918,9 @@ if ( -e "$dir/setup.py" ) {
 	    if ($recurse_python == 1) {
 		foreach (@rawpythondeps) {
 		    my $ptempdir = tempdir();
-		    $purl = `easy_install -eb $ptempdir "$_" 2>/dev/null`;
-		    $purl =~ s/#.*//;
-		    @purllist = $purl =~ m/Downloading (http:\/\/.*\n)/g;
+		    $purl = `easy_install -aeb $ptempdir "$_" 2>/dev/null`;
+		    $purl =~ s/#.*//g;
+		    @purllist = $purl =~ m/Downloading (.*:\/\/.*\n)/g;
 		    chomp(@purllist);
 		    
 		    # Remove empty lines