Преглед на файлове

perl: Add check for non-arch Storable.pm file

Under unknown conditions, Storable.pm will be placed in the base library
directory instead of under the arch specific one. This causes build
issues, see https://bugzilla.yoctoproject.org/show_bug.cgi?id=13946. To
try and catch this happening, add an explicit check for the bad file
existing and fail the build if it is found.

[YOCTO #13946]

Signed-off-by: Joshua Watt <JPEWhacker@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Joshua Watt преди 3 години
родител
ревизия
140ec7b71b
променени са 1 файла, в които са добавени 5 реда и са изтрити 0 реда
  1. 5 0
      meta/recipes-devtools/perl/perl_5.32.0.bb

+ 5 - 0
meta/recipes-devtools/perl/perl_5.32.0.bb

@@ -139,6 +139,11 @@ do_install() {
     # Fix up shared library
     rm ${D}/${libdir}/perl5/${PV}/*/CORE/libperl.so
     ln -sf ../../../../libperl.so.${PERL_LIB_VER} $(echo ${D}/${libdir}/perl5/${PV}/*/CORE)/libperl.so
+
+    # Try to catch Bug #13946
+    if [ -e ${D}/${libdir}/perl5/${PV}/Storable.pm ]; then
+        bbfatal 'non-arch specific Storable.pm found! See https://bugzilla.yoctoproject.org/show_bug.cgi?id=13946'
+    fi
 }
 
 do_install_append_class-target() {