Quellcode durchsuchen

alsa-state: ignore 'No soundcards found' error in pkg_postinst

If there is no soundcards on the target (e.g. qemu), the pkp_postinst
function will report an error:
  alsactl: load_state:1735: No soundcards found...
  pkg_run_script: package "alsa-state" postinst script returned status 19.
  opkg_configure: alsa-state.postinst returned 19.

Pass '-g' option to alsactl to ignore this error.

Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Yi Zhao vor 4 Jahren
Ursprung
Commit
100fce2a65
1 geänderte Dateien mit 1 neuen und 1 gelöschten Zeilen
  1. 1 1
      meta/recipes-bsp/alsa-state/alsa-state.bb

+ 1 - 1
meta/recipes-bsp/alsa-state/alsa-state.bb

@@ -62,7 +62,7 @@ pkg_postinst_${PN}() {
 	then
 		if test -x ${sbindir}/alsactl
 		then
-			${sbindir}/alsactl -f ${localstatedir}/lib/alsa/asound.state restore
+			${sbindir}/alsactl -g -f ${localstatedir}/lib/alsa/asound.state restore
 		fi
 	fi
 }