Browse Source

weston-init: Allow setting idle time to 0

Add a PACKAGECONFIG that can be used to set the idle-time to 0. This is
useful for always on machine (such as kiosks) and for debugging.

Signed-off-by: Alistair Francis <alistair@alistair23.me>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Alistair 3 years ago
parent
commit
082902a3e9
1 changed files with 8 additions and 0 deletions
  1. 8 0
      meta/recipes-graphics/wayland/weston-init.bb

+ 8 - 0
meta/recipes-graphics/wayland/weston-init.bb

@@ -15,6 +15,10 @@ SRC_URI = "file://init \
 
 S = "${WORKDIR}"
 
+PACKAGECONFIG ??= ""
+
+PACKAGECONFIG[no-idle-timeout] = ",,"
+
 DEFAULTBACKEND ??= ""
 DEFAULTBACKEND_qemuall ?= "fbdev"
 DEFAULTBACKEND_qemuarm64 = "drm"
@@ -45,6 +49,10 @@ do_install() {
         if [ -n "${DEFAULTBACKEND}" ]; then
 		sed -i -e "/^\[core\]/a backend=${DEFAULTBACKEND}-backend.so" ${D}${sysconfdir}/xdg/weston/weston.ini
 	fi
+
+	if [ "${@bb.utils.contains('PACKAGECONFIG', 'no-idle-timeout', 'yes', 'no', d)}" = "yes" ]; then
+		echo "idle-time=0" >> ${D}${sysconfdir}/xdg/weston/weston.ini
+	fi
 }
 
 inherit update-rc.d features_check systemd