Sfoglia il codice sorgente

sato-screenshot: improve .la removal

Don't assume that the .la files are installed, because some libtool
alternatives don't install these.

Signed-off-by: Ross Burton <ross.burton@arm.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
(cherry picked from commit e545ae3a7961111ceb4e2a468e9ec53cebfed721)
Signed-off-by: Steve Sakoman <steve@sakoman.com>
Ross Burton 3 anni fa
parent
commit
07910054c7

+ 1 - 1
meta/recipes-sato/sato-screenshot/sato-screenshot_0.3.bb

@@ -21,7 +21,7 @@ inherit autotools pkgconfig features_check
 FILES_${PN} += "${libdir}/matchbox-panel/*.so"
 
 do_install_append () {
-	rm ${D}${libdir}/matchbox-panel/*.la
+	rm -f ${D}${libdir}/matchbox-panel/*.la
 }
 
 # The matchbox-panel-2 requires x11 in DISTRO_FEATURES