qemu_2.5.0.bb 911 B

12345678910111213141516171819202122232425262728
  1. require recipes-devtools/qemu/qemu.inc
  2. SRC_URI = "gitsm://github.com/riscv/riscv-qemu.git;destsuffix=${S};branch=master \
  3. file://0001-Replace-struct-ucontext-with-ucontext_t-type.patch \
  4. "
  5. SRCREV = "ff36f2f77ec3e6a6211c63bfe1707ec057b12f7d"
  6. SRC_URI_remove_class-native = "\
  7. file://fix-libcap-header-issue-on-some-distro.patch \
  8. file://cpus.c-qemu_cpu_kick_thread_debugging.patch \
  9. "
  10. LIC_FILES_CHKSUM = "file://${S}/COPYING;md5=441c28d2cf86e15a37fa47e15a72fbac"
  11. QEMU_TARGETS = "riscv64 riscv32"
  12. EXTRA_OECONF_remove = "--disable-numa --disable-lzo --disable-opengl --disable-gnutls"
  13. COMPATIBLE_HOST_class-target_mips64 = "null"
  14. do_install() {
  15. export STRIP="true"
  16. autotools_do_install
  17. install -d ${D}${datadir}/qemu
  18. # Prevent QA warnings about installed ${localstatedir}/run
  19. if [ -d ${D}${localstatedir}/run ]; then rmdir ${D}${localstatedir}/run; fi
  20. }