riscv-fesvr.bb 762 B

123456789101112131415161718192021222324252627
  1. SUMMARY = "RISC-V Front-end Server"
  2. DESCRIPTION = "RISC-V Front-end Server"
  3. LICENSE = "GPLv2+"
  4. LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.GPLv2;md5=751419260aa954499f7abaabaa882bbe"
  5. SRCREV = "8d108a0a647901550d95925549337c2c3aec9ac8"
  6. SRC_URI = "git://github.com/riscv/riscv-fesvr.git \
  7. file://fesvr-makefile.patch"
  8. inherit autotools gettext cross-canadian
  9. BBCLASSEXTEND = "native nativesdk"
  10. S = "${WORKDIR}/git"
  11. do_configure_prepend () {
  12. if [ ! -e ${S}/acinclude.m4 ]; then
  13. cp ${S}/aclocal.m4 ${S}/acinclude.m4
  14. fi
  15. }
  16. do_install_append () {
  17. # Make install doesn't properly install these
  18. oe_libinstall -so libfesvr ${D}${libdir}
  19. }
  20. COMPATIBLE_HOST_class-target = "(riscv64|riscv32).*-linux"