u-boot_2019.04.bbappend 2.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748
  1. FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
  2. SRC_URI += "file://0001-riscv-add-infrastructure-for-calling-functions-on-ot.patch \
  3. file://0002-riscv-import-the-supervisor-binary-interface-header-.patch \
  4. file://0003-riscv-implement-IPI-platform-functions-using-SBI.patch \
  5. file://0004-riscv-delay-initialization-of-caches-and-debug-UART.patch \
  6. file://0005-riscv-save-hart-ID-in-register-tp-instead-of-s0.patch \
  7. file://0006-riscv-add-support-for-multi-hart-systems.patch \
  8. file://0007-riscv-boot-images-passed-to-bootm-on-all-harts.patch \
  9. file://0008-riscv-do-not-rely-on-hart-ID-passed-by-previous-boot.patch \
  10. file://0009-riscv-hang-if-relocation-of-secondary-harts-fails.patch \
  11. file://0010-riscv-fu540-enable-SMP.patch \
  12. file://0011-riscv-qemu-enable-SMP.patch \
  13. file://0012-riscv-Add-a-SYSCON-driver-for-Andestech-s-PLIC.patch \
  14. file://0013-riscv-Add-a-SYSCON-driver-for-Andestech-s-PLMT.patch \
  15. file://0014-riscv-ax25-Add-platform-specific-Kconfig-options.patch \
  16. file://0015-riscv-ax25-Andes-specific-cache-shall-only-support-i.patch \
  17. file://0016-riscv-dts-ae350-support-SMP.patch \
  18. file://0017-riscv-ae350-enable-SMP.patch \
  19. file://0018-riscv-dts-fix-CONFIG_DEFAULT_DEVICE_TREE-failure.patch \
  20. file://0001-sifive-fu540-Set-default-arguments-to-help-booting.patch \
  21. file://tftp-boot.txt \
  22. "
  23. DEPENDS += "u-boot-tools-native"
  24. # Overwrite this for your server
  25. TFTP_SERVER_IP ?= "127.0.0.1"
  26. do_configure_prepend() {
  27. sed -i -e 's,@SERVERIP@,${TFTP_SERVER_IP},g' ${S}/include/configs/sifive-fu540.h
  28. if [ -f "${WORKDIR}/${UBOOT_ENV}.txt" ]; then
  29. mkimage -O linux -T script -C none -n "U-Boot boot script" \
  30. -d ${WORKDIR}/${UBOOT_ENV}.txt ${WORKDIR}/boot.scr.uimg
  31. fi
  32. }
  33. do_deploy_append () {
  34. if [ -f "${WORKDIR}/boot.scr.uimg" ]; then
  35. install -d ${DEPLOY_DIR_IMAGE}
  36. install -m 755 ${WORKDIR}/boot.scr.uimg ${DEPLOY_DIR_IMAGE}
  37. fi
  38. }
  39. addtask deploy after do_install
  40. FILES_${PN} += "/boot/boot.scr.uimg"