linux-mainline_5.1.bb 1.3 KB

12345678910111213141516171819202122232425262728293031323334
  1. require recipes-kernel/linux/linux-mainline-common.inc
  2. LINUX_VERSION ?= "5.1.x"
  3. KERNEL_VERSION_SANITY_SKIP="1"
  4. BRANCH = "linux-5.1.y"
  5. SRCREV = "${AUTOREV}"
  6. SRC_URI = " \
  7. git://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git;branch=${BRANCH} \
  8. "
  9. # Out of tree patches required for HiFive Unleashed
  10. SRC_URI_append_freedom-u540 = " \
  11. file://0001-tty-serial-add-driver-for-the-SiFive-UART.patch \
  12. file://0002-gemgxl-mgmt-implement-clock-switch-for-GEM-tx_clk.patch \
  13. file://0003-u54-prci-driver-for-core-U54-clocks.patch \
  14. file://0004-u54-prci-driver-for-core-U54-clocks.patch \
  15. file://0005-gpio-sifive-support-GPIO-on-SiFive-SoCs.patch \
  16. file://0006-pwm-sifive-add-a-driver-for-SiFive-SoC-PWM.patch \
  17. file://0007-RISC-V-Networking-fix-Hack.patch \
  18. file://0008-pcie-microsemi-Add-support-for-the-Vera-board-root-c.patch \
  19. file://0009-HACK-Revert-of-device-Really-only-set-bus-DMA-mask-w.patch \
  20. file://0010-HACK-radeon-Don-t-set-PCI-DMA-mask.patch \
  21. "
  22. # Fix a breakage with the current 32bit glibc fork
  23. SRC_URI_append_qemuriscv32 = " file://0001-Revert-riscv-Use-latest-system-call-ABI.patch"
  24. # qemu uses in-tree defconfig
  25. # freedom-u540 uses out-of-tree defconfig
  26. SRC_URI_append_freedom-u540 = " file://defconfig"
  27. KBUILD_DEFCONFIG_qemuriscv32 = "rv32_defconfig"
  28. KBUILD_DEFCONFIG_qemuriscv64 = "defconfig"