u-boot_2019.07.bbappend 2.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657
  1. FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
  2. SRC_URI_append_freedom-u540 = " \
  3. file://0001-sifive-fu540-config-Add-mmc0-as-a-boot-target-device.patch \
  4. file://0002-net-macb-sync-header-definitions-as-taken-from-Linux.patch \
  5. file://0003-net-macb-add-support-for-faster-clk-rates.patch \
  6. file://0004-net-macb-use-bit-access-macro-from-header-file.patch \
  7. file://0005-net-macb-add-support-for-SGMII-phy-interface.patch \
  8. file://0006-net-macb-add-dma_burst_length-config.patch \
  9. file://0007-net-macb-apply-sane-DMA-configuration.patch \
  10. file://0008-clk-sifive-Factor-out-PLL-library-as-separate-module.patch \
  11. file://0009-clk-sifive-Sync-up-WRPLL-library-with-upstream-Linux.patch \
  12. file://0010-clk-sifive-Sync-up-DT-bindings-header-with-upstream-.patch \
  13. file://0011-clk-sifive-Sync-up-main-driver-with-upstream-Linux.patch \
  14. file://0012-clk-sifive-Drop-GEMGXL-clock-driver.patch \
  15. file://0013-net-macb-Extend-MACB-driver-for-SiFive-Unleashed-boa.patch \
  16. file://0014-riscv-sifive-fu540-Setup-ethaddr-env-variable-using-.patch \
  17. file://0015-doc-sifive-fu540-Update-README-for-steps-to-create-F.patch \
  18. file://0016-net-macb-Fix-check-for-little-endian-system-in.patch \
  19. file://0017-spi-Add-SiFive-SPI-driver.patch \
  20. file://0018-mmc-skip-select_mode_and_width-for-MMC-SPI-host.patch \
  21. file://0019-mmc-mmc_spi-Re-write-driver-using-DM-framework.patch \
  22. file://0020-riscv-sifive-fu540-Enable-SiFive-SPI-and-MMC-SPI-dri.patch \
  23. file://0021-doc-sifive-fu540-Update-README-for-SiFive-SPI-and-MM.patch \
  24. file://0022-net-macb-Extend-MACB-driver-for-SiFive-Unleashed-boa.patch \
  25. file://tftp-mmc-boot.txt \
  26. "
  27. SRC_URI_append_freedom-u540_sota = " file://uEnv.txt"
  28. DEPENDS_append_freedom-u540 = " u-boot-tools-native"
  29. # Overwrite this for your server
  30. TFTP_SERVER_IP ?= "127.0.0.1"
  31. do_configure_prepend_freedom-u540() {
  32. sed -i -e 's,@SERVERIP@,${TFTP_SERVER_IP},g' ${WORKDIR}/tftp-mmc-boot.txt
  33. if [ -f "${WORKDIR}/${UBOOT_ENV}.txt" ]; then
  34. mkimage -O linux -T script -C none -n "U-Boot boot script" \
  35. -d ${WORKDIR}/${UBOOT_ENV}.txt ${WORKDIR}/boot.scr.uimg
  36. fi
  37. }
  38. do_deploy_append_freedom-u540() {
  39. if [ -f "${WORKDIR}/boot.scr.uimg" ]; then
  40. install -d ${DEPLOY_DIR_IMAGE}
  41. install -m 755 ${WORKDIR}/boot.scr.uimg ${DEPLOY_DIR_IMAGE}
  42. fi
  43. if [ -f "${WORKDIR}/uEnv.txt" ]; then
  44. install -d ${DEPLOY_DIR_IMAGE}
  45. install -m 755 ${WORKDIR}/uEnv.txt ${DEPLOY_DIR_IMAGE}
  46. fi
  47. }
  48. FILES_${PN}_append_freedom-u540 = " /boot/boot.scr.uimg"