Browse Source

Add linux-thead_5.10.4.bb

lihm 3 years ago
parent
commit
eaa2df4fbb
2 changed files with 28 additions and 1 deletions
  1. 1 1
      conf/machine/ice.conf
  2. 27 0
      recipes-kernel/linux/linux-thead_5.10.4.bb

+ 1 - 1
conf/machine/ice.conf

@@ -9,7 +9,7 @@ SERIAL_CONSOLES = "115200;ttySIF0"
 MACHINE_EXTRA_RRECOMMENDS += "kernel-modules"
 
 IMAGE_FSTYPES += "ext4"
-KERNEL_DEVICETREE ?= "thead/light-c910.dtb"
+KERNEL_DEVICETREE ?= "thead/ice.dtb"
 
 UBOOT_ENTRYPOINT = "0x80200000"
 UBOOT_DTB_LOADADDRESS = "0x82200000"

+ 27 - 0
recipes-kernel/linux/linux-thead_5.10.4.bb

@@ -0,0 +1,27 @@
+inherit kernel
+require recipes-kernel/linux/linux-yocto.inc
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/files/xuantie-c910:"
+
+SRC_URI = " \
+    git://gitee.com/thead-linux/kernel.git;branch=${KMACHINE};protocol=http \
+"
+
+LINUX_VERSION ?= "${PV}"
+LINUX_VERSION_EXTENSION ?= "-thead"
+
+SRCREV="${AUTOREV}"
+
+DEPENDS += "elfutils-native"
+
+COMPATIBLE_MACHINE = "${MACHINE}"
+
+S = "${WORKDIR}/linux-${PV}"
+
+# KBUILD_DEFCONFIG_qemu64-c910 = "qemux-c910_defconfig"
+KBUILD_DEFCONFIG_ice = "ice_defconfig"
+# KBUILD_DEFCONFIG_ice-c910 = "ice-c910_defconfig"
+
+KCONFIG_MODE="--alldefconfig"