Browse Source

linux: Update to 5.1 stable

This patch does the following:
 - Update the current linux-mainline_5.1 recipe to AUTOREV from the
   stable branch
 - Use the linux-mainline_5.1 by default for the HiFive Unleashed
 - Remove the older linux-riscv_5.0 recipe
 - Rename the common include to linux-mainline-common.inc

Signed-off-by: Alistair Francis <alistair.francis@wdc.com>
Alistair Francis 5 years ago
parent
commit
e3e7f75961

+ 1 - 1
conf/machine/freedom-u540.conf

@@ -9,7 +9,7 @@ MACHINE_FEATURES = "screen keyboard ext2 ext3 serial"
 
 KERNEL_IMAGETYPE = "Image"
 
-PREFERRED_PROVIDER_virtual/kernel ?= "linux-riscv"
+PREFERRED_PROVIDER_virtual/kernel ?= "linux-mainline"
 
 GDBVERSION = "riscv"
 

+ 2 - 2
recipes-kernel/linux/linux-riscv-common.inc → recipes-kernel/linux/linux-mainline-common.inc

@@ -1,4 +1,4 @@
-DESCRIPTION = "RISC-V Linux Kernel"
+DESCRIPTION = "Mainline Linux Kernel"
 SECTION = "kernel"
 LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://${S}/COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://${S}/COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
 inherit kernel
 require recipes-kernel/linux/linux-yocto.inc
 
-LINUX_VERSION_EXTENSION = "-riscv"
+LINUX_VERSION_EXTENSION = ""
 
 PV = "${LINUX_VERSION}+git${SRCPV}"
 

+ 6 - 12
recipes-kernel/linux/linux-mainline_5.1.bb

@@ -1,15 +1,11 @@
-require recipes-kernel/linux/linux-riscv-common.inc
-
-DESCRIPTION = "Mainline Linux Kernel"
+require recipes-kernel/linux/linux-mainline-common.inc
 
 LINUX_VERSION ?= "5.1"
-LINUX_VERSION_EXTENSION = ""
 
-# Update this to point to the stable release branches after the official release
-BRANCH = "master"
+BRANCH = "linux-5.1.y"
 SRCREV = "${AUTOREV}"
 SRC_URI = " \
-    git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git;branch=${BRANCH} \
+    git://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git;branch=${BRANCH} \
 "
 
 # Out of tree patches required for HiFive Unleashed
@@ -26,14 +22,12 @@ SRC_URI_append_freedom-u540 = " \
     file://0010-HACK-radeon-Don-t-set-PCI-DMA-mask.patch \
 "
 
+# Fix a breakage with the current 32bit glibc fork
+SRC_URI_append_qemuriscv32 = " file://0001-Revert-riscv-Use-latest-system-call-ABI.patch"
+
 # qemu uses in-tree defconfig
 # freedom-u540 uses out-of-tree defconfig
 SRC_URI_append_freedom-u540 = " file://defconfig"
 
-# Fix a breakage with the current 32bit glibc fork
-SRC_URI_append_qemuriscv32 = " file://0001-Revert-riscv-Use-latest-system-call-ABI.patch"
-
 KBUILD_DEFCONFIG_qemuriscv32 = "rv32_defconfig"
 KBUILD_DEFCONFIG_qemuriscv64 = "defconfig"
-
-KERNEL_VERSION_SANITY_SKIP = "1"

+ 0 - 18
recipes-kernel/linux/linux-riscv_5.0.bb

@@ -1,18 +0,0 @@
-require recipes-kernel/linux/linux-riscv-common.inc
-
-LINUX_VERSION ?= "5.0"
-
-BRANCH = "hifive-unleashed-5.0"
-SRCREV = "1fc509f5f47f0ef5b723666ab3670898ac3208a1"
-
-SRC_URI = " \
-    git://github.com/alistair23/linux.git;branch=${BRANCH} \
-"
-
-# qemu uses in-tree defconfig
-# freedom-u540 uses out-of-tree defconfig
-SRC_URI_append_freedom-u540 = " file://defconfig"
-SRC_URI_append_qemuriscv32 = " file://32bit.cfg"
-
-KBUILD_DEFCONFIG_qemuriscv32 = "defconfig"
-KBUILD_DEFCONFIG_qemuriscv64 = "defconfig"