Forráskód Böngészése

d1: add the linux-kernel bb file for d1

Signed-off-by: Ma Jun <majun258@linux.alibaba.com>
Ma Jun 3 éve
szülő
commit
d75bac7d59

+ 1 - 1
recipes-kernel/linux/linux-thead_5.10.4.bb

@@ -16,7 +16,7 @@ SRCREV="${AUTOREV}"
 
 DEPENDS += "elfutils-native"
 
-COMPATIBLE_MACHINE = "${MACHINE}"
+COMPATIBLE_MACHINE = "ice"
 
 S = "${WORKDIR}/linux-${PV}"
 

+ 1 - 1
recipes-kernel/linux/linux-thead_5.4.36.bb

@@ -24,7 +24,7 @@ SRCREV="${AUTOREV}"
 
 DEPENDS += "elfutils-native"
 
-COMPATIBLE_MACHINE = "${MACHINE}"
+COMPATIBLE_MACHINE = "ice"
 
 S = "${WORKDIR}/linux-${PV}"
 

+ 51 - 0
recipes-kernel/linux/linux-thead_5.4.61.bb

@@ -0,0 +1,51 @@
+inherit kernel
+require recipes-kernel/linux/linux-yocto.inc
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
+
+#FILESEXTRAPATHS_prepend := "${THISDIR}/files/xuantie-c910:"
+
+#SRC_URI = " \
+#    http://gitlab.alibaba-inc.com:thead-linux/d1_linux-kernel.git;branch=master \
+#    "
+#SRC_URI[sha256sum] = "acea641977739e9060800e56a32d137794ea7ed011f24353ba40448e2a6ba36a"
+
+SRC_URI = " \
+    git://mj145409@gitlab.alibaba-inc.com/thead-linux/d1_linux-kernel.git;branch=master;protocol=https \
+    "
+#SRC_URI[sha256sum] = "9e841db240d4f7161ac1c931bd889dc17eb9b076"
+#https://code.aone.alibaba-inc.com/thead-linux/d1_linux-kernel/repository/archive.tar.gz?ref=master
+#git@gitlab.alibaba-inc.com:thead-linux/d1_linux-kernel.git
+#SRC_URI[kernel.md5sum] = "4c4edf3e7d127e4f1a471aa3a370f3e7"
+#SRC_URI[kernel.sha256sum] = "b9faea98122e8316af8fb428c942e81797b5d28a8fc59a24a4e47959e3765b8d"
+
+LINUX_VERSION ?= "${PV}"
+LINUX_VERSION_EXTENSION ?= "-thead"
+
+SRCREV="${AUTOREV}"
+
+DEPENDS += "elfutils-native"
+
+COMPATIBLE_MACHINE = "d1"
+
+S = "${WORKDIR}/linux-${PV}"
+
+# KBUILD_DEFCONFIG_qemu64-c910 = "qemux-c910_defconfig"
+# KBUILD_DEFCONFIG_light-c910 = "light-c910_defconfig"
+# KBUILD_DEFCONFIG_ice-c910 = "ice-c910_defconfig"
+
+do_configure_append() {
+  [ -d ${STAGING_KERNEL_DIR} ] && rm -rf ${STAGING_KERNEL_DIR}
+  [ -f ${STAGING_KERNEL_DIR} ] && rm -rf ${STAGING_KERNEL_DIR}
+
+  ln -s ${S}  ${STAGING_KERNEL_DIR}
+}
+do_install_append() {
+
+   [ -f ${STAGING_KERNEL_BUILDDIR} ] && rm -rf ${STAGING_KERNEL_BUILDDIR}
+   [ -d ${STAGING_KERNEL_BUILDDIR} ] && rm -rf ${STAGING_KERNEL_BUILDDIR}
+
+   ln -s ${B}  ${STAGING_KERNEL_BUILDDIR}
+}
+
+KCONFIG_MODE="--alldefconfig"