Browse Source

recipes-kernel: linux-riscv: Update to 5.0 release

Signed-off-by: Alistair Francis <alistair.francis@wdc.com>
Alistair Francis 5 years ago
parent
commit
d6e7e6f7db

+ 1 - 1
conf/machine/freedom-u540.conf

@@ -10,7 +10,7 @@ MACHINE_FEATURES = "screen keyboard ext2 ext3 serial"
 KERNEL_IMAGETYPE = "vmlinux"
 
 PREFERRED_PROVIDER_virtual/kernel ?= "linux-riscv"
-PREFERRED_VERSION_linux-riscv ?= "4.19%"
+PREFERRED_VERSION_linux-riscv ?= "5.0%"
 
 GDBVERSION = "riscv"
 

+ 2 - 2
recipes-kernel/linux/files/freedom-u540/defconfig

@@ -17,8 +17,7 @@ CONFIG_BPF_SYSCALL=y
 CONFIG_EMBEDDED=y
 CONFIG_SMP=y
 CONFIG_HZ_100=y
-CONFIG_CMDLINE_BOOL=y
-CONFIG_CMDLINE="earlyprintk root=/dev/mmcblk0p2 rootwait"
+CONFIG_CMDLINE="earlycon=sbi root=/dev/mmcblk0p2 rootwait"
 CONFIG_MODULES=y
 CONFIG_MODULE_UNLOAD=y
 # CONFIG_BLK_DEV_BSG is not set
@@ -106,6 +105,7 @@ CONFIG_SERIAL_8250_CONSOLE=y
 # CONFIG_SERIAL_8250_PCI is not set
 CONFIG_SERIAL_8250_RT288X=y
 CONFIG_SERIAL_OF_PLATFORM=y
+CONFIG_SERIAL_EARLYCON_RISCV_SBI=y
 CONFIG_SERIAL_JSM=y
 CONFIG_SERIAL_SIFIVE=y
 CONFIG_SERIAL_SIFIVE_CONSOLE=y

+ 1 - 1
recipes-kernel/linux/linux-riscv-common.inc

@@ -1,7 +1,7 @@
 DESCRIPTION = "RISC-V Linux Kernel"
 SECTION = "kernel"
 LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://${S}/COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
+LIC_FILES_CHKSUM = "file://${S}/COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
 
 inherit kernel
 require recipes-kernel/linux/linux-yocto.inc

+ 0 - 2
recipes-kernel/linux/linux-riscv_4.19.bb

@@ -1,7 +1,5 @@
 require recipes-kernel/linux/linux-riscv-common.inc
 
-LIC_FILES_CHKSUM = "file://${S}/COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
-
 LINUX_VERSION ?= "4.19"
 
 BRANCH = "riscv-linux-4.19"

+ 2 - 7
recipes-kernel/linux/linux-riscv_5.0.bb

@@ -1,11 +1,9 @@
 require recipes-kernel/linux/linux-riscv-common.inc
 
-LIC_FILES_CHKSUM = "file://${S}/COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
-
-LINUX_VERSION ?= "5.0-rc3"
+LINUX_VERSION ?= "5.0"
 
 BRANCH = "hifive-unleashed-5.0"
-SRCREV = "02225ef0623657aed2b27144238be46c6c8e1291"
+SRCREV = "1fc509f5f47f0ef5b723666ab3670898ac3208a1"
 
 SRC_URI = " \
     git://github.com/alistair23/linux.git;branch=${BRANCH} \
@@ -17,6 +15,3 @@ SRC_URI = " \
 SRC_URI_append_freedom-u540 = " file://defconfig"
 
 SRC_URI_append_qemuriscv32 = " file://32bit.cfg"
-
-# Remove this after official 5.0 release
-DEFAULT_PREFERENCE = "-1"