Browse Source

gdb: Remove the RISC-V GDB

Now that GDB 8.3 has been merged into the meta layer we no longer need a
custom GDB version.

Signed-off-by: Alistair Francis <alistair.francis@wdc.com>
Alistair Francis 5 years ago
parent
commit
4157f3e012

+ 0 - 2
conf/machine/baremetal-riscv32.conf

@@ -6,8 +6,6 @@ DEFAULTTUNE = "riscv32"
 require conf/machine/include/qemu.inc
 require conf/machine/include/tune-riscv.inc
 
-GDBVERSION = "riscv"
-
 # qemuboot options
 QB_MACHINE = "-machine virt"
 QB_DEFAULT_KERNEL = "fw_payload.elf"

+ 0 - 2
conf/machine/baremetal-riscv64.conf

@@ -6,8 +6,6 @@ DEFAULTTUNE = "riscv64"
 require conf/machine/include/qemu.inc
 require conf/machine/include/tune-riscv.inc
 
-GDBVERSION = "riscv"
-
 # qemuboot options
 QB_MACHINE = "-machine virt"
 QB_DEFAULT_KERNEL = "fw_payload.elf"

+ 0 - 2
conf/machine/freedom-u540.conf

@@ -11,8 +11,6 @@ KERNEL_IMAGETYPE = "Image"
 
 PREFERRED_PROVIDER_virtual/kernel ?= "linux-mainline"
 
-GDBVERSION = "riscv"
-
 EXTRA_IMAGEDEPENDS += "opensbi"
 RISCV_SBI_PLAT = "sifive/fu540"
 

+ 0 - 2
conf/machine/include/qemuriscv.inc

@@ -7,8 +7,6 @@ MACHINE_FEATURES = "screen keyboard ext2 ext3 serial"
 
 KERNEL_IMAGETYPE = "Image"
 
-GDBVERSION = "riscv"
-
 SERIAL_CONSOLES ?= "115200;ttyS0 115200;hvc0"
 
 IMAGE_FSTYPES_append = " ext4"

+ 0 - 5
recipes-devtools/gdb/gdb-cross-canadian_riscv.bb

@@ -1,5 +0,0 @@
-require recipes-devtools/gdb/gdb-common.inc
-require recipes-devtools/gdb/gdb-cross-canadian.inc
-require gdb-${PV}.inc
-
-DEPENDS += "bison-native"

+ 0 - 2
recipes-devtools/gdb/gdb-cross_riscv.bb

@@ -1,2 +0,0 @@
-require recipes-devtools/gdb/gdb-cross.inc
-require gdb-${PV}.inc

+ 0 - 10
recipes-devtools/gdb/gdb-riscv.inc

@@ -1,10 +0,0 @@
-LICENSE = "GPLv2 & GPLv3 & LGPLv2 & LGPLv3"
-LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
-                    file://COPYING3;md5=d32239bcb673463ab874e80d47fae504 \
-                    file://COPYING3.LIB;md5=6a6a8e020838b23406c81b19c1d46df6 \
-                    file://COPYING.LIB;md5=9f604d8a4f8e74f4f5140845a21b6674"
-
-SRCREV = "9d1447e09d4aa673826039321163b5a684e8e043"
-SRC_URI = "git://sourceware.org/git/binutils-gdb.git"
-S = "${WORKDIR}/git"
-

+ 0 - 31
recipes-devtools/gdb/gdb_riscv.bb

@@ -1,31 +0,0 @@
-require recipes-devtools/gdb/gdb.inc
-require gdb-${PV}.inc
-
-DEPENDS += "bison-native"
-
-inherit python3-dir
-
-EXTRA_OEMAKE_append_libc-musl = "\
-                                 gt_cv_func_gnugettext1_libc=yes \
-                                 gt_cv_func_gnugettext2_libc=yes \
-                                 gl_cv_func_gettimeofday_clobber=no \
-                                "
-
-do_configure_prepend() {
-	if [ "${@bb.utils.filter('PACKAGECONFIG', 'python', d)}" ]; then
-		cat > ${WORKDIR}/python << EOF
-#!/bin/sh
-case "\$2" in
-	--includes) echo "-I${STAGING_INCDIR}/${PYTHON_DIR}${PYTHON_ABI}/" ;;
-	--ldflags) echo "-Wl,-rpath-link,${STAGING_LIBDIR}/.. -Wl,-rpath,${libdir}/.. -lpthread -ldl -lutil -lm -lpython${PYTHON_BASEVERSION}${PYTHON_ABI}" ;;
-	--exec-prefix) echo "${exec_prefix}" ;;
-	*) exit 1 ;;
-esac
-exit 0
-EOF
-		chmod +x ${WORKDIR}/python
-	fi
-}
-CFLAGS_append_libc-musl = " -Drpl_gettimeofday=gettimeofday"
-
-ALLOW_EMPTY_gdbserver = "1"