Browse Source

uboot: Add the uboot bb file for d1(2018.05)

Signed-off-by: Ma Jun <majun258@linux.alibaba.com>
Ma Jun 3 years ago
parent
commit
211afe9893

+ 2 - 1
conf/machine/d1.conf

@@ -10,6 +10,7 @@ MACHINE_EXTRA_RRECOMMENDS += "kernel-modules"
 
 IMAGE_FSTYPES += "ext4"
 KERNEL_DEVICETREE ?= "sunxi/d1.dtb"
-UBOOT_MACHINE = "ice_evb_c910_defconfig"
+#UBOOT_MACHINE = "sun20iw1p1_defconfig"
+UBOOT_MACHINE = "d1_defconfig"
 UBOOT_ENTRYPOINT = "0x80200000"
 UBOOT_DTB_LOADADDRESS = "0x82200000"

+ 2 - 0
recipes-bsp/u-boot/u-boot_%.bbappend

@@ -10,6 +10,8 @@ SRC_URI_append_freedom-u540_sota = " file://uEnv.txt"
 
 DEPENDS_append_freedom-u540 = " u-boot-tools-native"
 
+COMPATIBLE_MACHINE = "ice"
+
 # Overwrite this for your server
 TFTP_SERVER_IP ?= "127.0.0.1"
 

+ 13 - 0
recipes-bsp/u-boot/u-boot_2018.05.bbappend

@@ -0,0 +1,13 @@
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6"
+PE = "1"
+
+#SRCREV="0a88ac94ab4c4c7942423d3b447e6a147fae7fbd"
+SRCREV="${AUTOREV}"
+#PV = "0.1+git${SRCPV}"
+SRC_URI = " \
+    git://git@gitlab.alibaba-inc.com/thead-linux/d1_u-boot.git;branch=d1-miniapp;protocol=ssh"
+
+COMPATIBLE_MACHINE = "d1"
+
+#B = "${WORKDIR}/git"