Browse Source

RISC-V:fix the source path of u-boot repository

liqiangguo 2 years ago
parent
commit
063d0558e6
1 changed files with 8 additions and 33 deletions
  1. 8 33
      recipes-bsp/u-boot/u-boot_%.bbappend

+ 8 - 33
recipes-bsp/u-boot/u-boot_%.bbappend

@@ -1,37 +1,12 @@
 FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
 
-SRC_URI_append_ice = " \
-            file://tftp-mmc-boot.txt \
-            file://0001-riscv64-910.patch \
-            file://0001-riscv64-C910-defconfig.patch \
-           "
-
-SRC_URI_append_freedom-u540_sota = " file://uEnv.txt"
-
-DEPENDS_append_freedom-u540 = " u-boot-tools-native"
-
-# Overwrite this for your server
-TFTP_SERVER_IP ?= "127.0.0.1"
+LIC_FILES_CHKSUM = "file://Licenses/README;md5=30503fd321432fc713238f582193b78e"
 
-do_configure_prepend_freedom-u540() {
-    sed -i -e 's,@SERVERIP@,${TFTP_SERVER_IP},g' ${WORKDIR}/tftp-mmc-boot.txt
-
-    if [ -f "${WORKDIR}/${UBOOT_ENV}.txt" ]; then
-        mkimage -O linux -T script -C none -n "U-Boot boot script" \
-            -d ${WORKDIR}/${UBOOT_ENV}.txt ${WORKDIR}/boot.scr.uimg
-    fi
-}
-
-do_deploy_append_freedom-u540() {
-    if [ -f "${WORKDIR}/boot.scr.uimg" ]; then
-        install -d ${DEPLOY_DIR_IMAGE}
-        install -m 755 ${WORKDIR}/boot.scr.uimg ${DEPLOY_DIR_IMAGE}
-    fi
-
-    if [ -f "${WORKDIR}/uEnv.txt" ]; then
-        install -d ${DEPLOY_DIR_IMAGE}
-        install -m 755 ${WORKDIR}/uEnv.txt ${DEPLOY_DIR_IMAGE}
-    fi
-}
+SRC_URI_append_ice = " \
+             file://tftp-mmc-boot.txt \
+            "
+SRC_URI = " \
+     git://gitee.com/thead-linux/u-boot.git;protocol=http \ 
+"
 
-FILES_${PN}_append_freedom-u540 = " /boot/boot.scr.uimg"
+SRCREV = "4f01a69ec30fdfa63413dd958314cb10008e32f6"