Browse Source

Fix gobject-introspection compile error.

tianshuliang 3 years ago
parent
commit
02a7d446b6

+ 1 - 0
conf/machine/include/thead-base.inc

@@ -5,6 +5,7 @@ TCMODE="external"
 TARGET_PREFIX="riscv64-linux-"
 TARGET_ARCH="riscv64"
 TARGET_OS="linux"
+QEMU_TOOLCHAIN_PATH="${HOME}/.thead/host/csky-qemu/bin/"
 EXTERNAL_TOOLCHAIN_SYSROOT="${EXTERNAL_TOOLCHAIN}/riscv64-buildroot-linux-gnu/sysroot"
 
 INSANE_SKIP_${PN} += "glibc-so gobject-introspection-so glibc-external"

+ 4 - 0
recipes-gnome/gmime/gmime_3.2.6.bbappend

@@ -0,0 +1,4 @@
+
+do_configure_prepend() {
+   cp -rf ${QEMU_TOOLCHAIN_PATH}/*  ${WORKDIR}/recipe-sysroot-native/usr/bin/ 
+}

+ 10 - 0
recipes-gnome/gobject-introspection/gobject-introspection_1.66.1.bbappend

@@ -0,0 +1,10 @@
+SUMMARY = "Middleware layer between GObject-using C libraries and language bindings"
+DESCRIPTION = "GObject Introspection is a project for providing machine \
+readable introspection data of the API of C libraries. This introspection \
+data can be used in several different use cases, for example automatic code \
+generation for bindings, API verification and documentation generation."
+HOMEPAGE = "https://wiki.gnome.org/action/show/Projects/GObjectIntrospection"
+
+do_configure_prepend() {
+   cp -rf ${QEMU_TOOLCHAIN_PATH}/*  ${WORKDIR}/recipe-sysroot-native/usr/bin/ 
+}