xfce4-power-manager_4.16.0.bb 1.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142
  1. SUMMARY = "Power manager for the Xfce desktop environment"
  2. HOMEPAGE = "http://goodies.xfce.org/projects/applications/xfce4-power-manager"
  3. SECTION = "x11"
  4. LICENSE = "GPLv2+"
  5. LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
  6. inherit xfce features_check
  7. REQUIRED_DISTRO_FEATURES = "x11"
  8. DEPENDS += "libnotify libxrandr virtual/libx11 libxext xfce4-panel upower libxscrnsaver"
  9. SRC_URI[sha256sum] = "eb9c587c01b502fa45a32e7fc2aba98fa6d8391475133883654f77e562c43bf3"
  10. EXTRA_OECONF = " \
  11. --enable-network-manager \
  12. --enable-panel-plugins \
  13. "
  14. PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'polkit', d)}"
  15. PACKAGECONFIG[polkit] = "--enable-polkit, --disable-polkit, polkit"
  16. PACKAGES += "xfce4-powermanager-plugin"
  17. FILES_${PN} += " \
  18. ${datadir}/polkit-1 \
  19. ${datadir}/metainfo \
  20. "
  21. FILES_xfce4-powermanager-plugin = " \
  22. ${libdir}/xfce4 \
  23. ${datadir}/xfce4 \
  24. "
  25. RDEPENDS_xfce4-powermanager-plugin = "${PN}"
  26. RDEPENDS_${PN} = "networkmanager ${@bb.utils.contains('DISTRO_FEATURES','systemd','','consolekit',d)}"
  27. # xfce4-brightness-plugin was replaced by xfce4-powermanager-plugin
  28. RPROVIDES_xfce4-powermanager-plugin += "xfce4-brightness-plugin"
  29. RREPLACES_xfce4-powermanager-plugin += "xfce4-brightness-plugin"
  30. RCONFLICTS_xfce4-powermanager-plugin += "xfce4-brightness-plugin"