xdebug_2.9.5.bb 1.0 KB

1234567891011121314151617181920212223242526272829303132333435
  1. SUMMARY = "Debugging and profiling extension for PHP"
  2. LICENSE = "Xdebug"
  3. LIC_FILES_CHKSUM = "file://LICENSE;md5=92d94a330d34ee6edc2638450736f119"
  4. DEPENDS = "php re2c-native"
  5. SRC_URI = "http://xdebug.org/files/xdebug-${PV}.tgz"
  6. SRC_URI[md5sum] = "c04be1bf225b768bf627dc92e5a1f9df"
  7. SRC_URI[sha256sum] = "775b1705109611b996d6a713fe14117a67846e157eb7dbf349bc0b055e861a10"
  8. UPSTREAM_CHECK_REGEX = "xdebug-(?P<pver>\d+(\.\d+)+)\.tgz"
  9. inherit autotools
  10. EXTRA_OECONF += "--enable-xdebug -with-php-config=${STAGING_BINDIR_CROSS}/php-config"
  11. do_configure() {
  12. cd ${S}
  13. ${STAGING_BINDIR_CROSS}/phpize
  14. cd ${B}
  15. # Running autoreconf as autotools_do_configure would do here
  16. # breaks the libtool configuration resulting in a failure later
  17. # in do_compile. It's possible this may be fixable, however the
  18. # easiest course of action for the moment is to avoid doing that.
  19. oe_runconf
  20. }
  21. do_install() {
  22. oe_runmake install INSTALL_ROOT=${D}
  23. }
  24. FILES_${PN} += "${libdir}/php*/extensions/*/*.so"
  25. FILES_${PN}-dbg += "${libdir}/php*/extensions/*/.debug"