python3-yarl_1.6.3.bb 650 B

12345678910111213141516171819202122232425262728
  1. SUMMARY = "The module provides handy URL class for url parsing and changing"
  2. HOMEPAGE = "https://github.com/aio-libs/yarl/"
  3. LICENSE = "Apache-2.0"
  4. LIC_FILES_CHKSUM = "file://LICENSE;md5=b334fc90d45983db318f54fd5bf6c90b"
  5. SRC_URI[sha256sum] = "8a9066529240171b68893d60dca86a763eae2139dd42f42106b03cf4b426bf10"
  6. SRC_URI += " \
  7. file://run-ptest \
  8. "
  9. PYPI_PACKAGE = "yarl"
  10. inherit pypi ptest setuptools3
  11. RDEPENDS_${PN} = "\
  12. ${PYTHON_PN}-multidict \
  13. ${PYTHON_PN}-idna \
  14. "
  15. RDEPENDS_${PN}-ptest += " \
  16. ${PYTHON_PN}-pytest \
  17. "
  18. do_install_ptest() {
  19. install -d ${D}${PTEST_PATH}/tests
  20. cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
  21. }