python3-xmltodict_0.12.0.bb 638 B

12345678910111213141516171819202122232425
  1. SUMMARY = "Makes working with XML feel like you are working with JSON"
  2. AUTHOR = "Martin Blech"
  3. HOMEPAGE = "https://github.com/martinblech/xmltodict"
  4. LICENSE = "MIT"
  5. LIC_FILES_CHKSUM = "file://LICENSE;md5=01441d50dc74476db58a41ac10cb9fa2"
  6. SRC_URI[md5sum] = "ddb2bd078cef4f7e3021a578034ad941"
  7. SRC_URI[sha256sum] = "50d8c638ed7ecb88d90561beedbf720c9b4e851a9fa6c47ebd64e99d166d8a21"
  8. PYPI_PACKAGE = "xmltodict"
  9. inherit pypi setuptools3 ptest
  10. SRC_URI += " \
  11. file://run-ptest \
  12. "
  13. RDEPENDS_${PN}-ptest += " \
  14. ${PYTHON_PN}-pytest \
  15. "
  16. do_install_ptest() {
  17. install -d ${D}${PTEST_PATH}/tests
  18. cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
  19. }