python3-xlrd_1.2.0.bb 1.0 KB

12345678910111213141516171819202122232425262728293031
  1. SUMMARY = "Library for developers to extract data from Microsoft Excel (tm) spreadsheet files"
  2. DESCRIPTION = "Extract data from Excel spreadsheets (.xls and .xlsx,\
  3. versions 2.0 onwards) on any platform. Pure Python (2.6, 2.7, 3.2+). \
  4. Strong support for Excel dates. Unicode-aware."
  5. HOMEPAGE = "http://www.python-excel.org/"
  6. LICENSE = "BSD-3-Clause"
  7. LIC_FILES_CHKSUM = "file://PKG-INFO;md5=5f4244d51fcc1e7cc2d43e96891b2f80"
  8. SRC_URI[md5sum] = "e5d5b96924d791b22898b622eb3e918e"
  9. SRC_URI[sha256sum] = "546eb36cee8db40c3eaa46c351e67ffee6eeb5fa2650b71bc4c758a29a1b29b2"
  10. SRC_URI += " \
  11. file://run-ptest \
  12. "
  13. inherit ptest pypi setuptools3
  14. RDEPENDS_${PN} += "${PYTHON_PN}-compression ${PYTHON_PN}-io ${PYTHON_PN}-pprint ${PYTHON_PN}-shell"
  15. RDEPENDS_${PN}-ptest += " \
  16. ${PYTHON_PN}-pytest \
  17. "
  18. do_install_ptest() {
  19. install -d ${D}${PTEST_PATH}/tests
  20. cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
  21. install -d ${D}${PTEST_PATH}/examples
  22. cp -rf ${S}/examples/* ${D}${PTEST_PATH}/examples/
  23. }
  24. BBCLASSEXTEND = "native nativesdk"